blob: 9407c25a5567e3bfdedc8a14aa74daaff6203cb7 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "GNOME session"
Andrew Geissler9aee5002022-03-30 16:27:02 +00002LICENSE = "GPL-2.0-only"
Andrew Geissler595f6302022-01-24 19:11:47 +00003LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4
5DEPENDS = " \
6 glib-2.0-native \
7 libxslt-native \
8 xmlto-native \
9 xtrans \
10 libice \
11 libsm \
12 virtual/libx11 \
13 gtk+3 \
14 gnome-desktop \
15 gsettings-desktop-schemas \
16 json-glib \
17"
18
19GNOMEBASEBUILDCLASS = "meson"
20
21inherit gnomebase gettext gsettings upstream-version-is-even features_check
22
23REQUIRED_DISTRO_FEATURES = "x11 polkit systemd pam gobject-introspection-data"
24
Patrick Williams03907ee2022-05-01 06:28:52 -050025SRC_URI[archive.sha256sum] = "3cca06053ab682926920951a7da95f8cc6d72da74c682c46d0a0653332969caa"
Andrew Geissler595f6302022-01-24 19:11:47 +000026
27PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', 'consolekit',d)}"
28
29PACKAGECONFIG[consolekit] = "-Dconsolekit=true, -Dconsolekit=false, consolekit"
30PACKAGECONFIG[systemd] = "-Dsystemd=true -Dsystemd_journal=true, -Dsystemd=false -Dsystemd_journal=false, systemd"
31
32FILES:${PN} += " \
33 ${datadir}/xsessions \
34 ${datadir}/wayland-sessions \
35 ${systemd_user_unitdir} \
36"
37
38RDEPENDS:${PN} += "gnome-shell gnome-settings-daemon gsettings-desktop-schemas"