blob: 2affcf754e56b63a0bb296e406e76748969d3904 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "The tdb library"
2HOMEPAGE = "http://tdb.samba.org/"
3SECTION = "libs"
Andrew Geissler9aee5002022-03-30 16:27:02 +00004LICENSE = "LGPL-3.0-or-later & GPL-3.0-or-later"
Andrew Geissler82c905d2020-04-13 13:39:40 -05005
6LIC_FILES_CHKSUM = "file://tools/tdbdump.c;endline=18;md5=b59cd45aa8624578126a8c98f48018c4 \
7 file://include/tdb.h;endline=27;md5=f5bb544641d3081821bcc1dd58310be6"
8
9SRC_URI = "https://samba.org/ftp/tdb/tdb-${PV}.tar.gz \
10 file://tdb-Add-configure-options-for-packages.patch \
Andrew Geissler595f6302022-01-24 19:11:47 +000011 file://0001-Fix-pyext_PATTERN-for-cross-compilation.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050012"
13
14SRC_URI[md5sum] = "e638e8890f743624a754304b3f994f4d"
15SRC_URI[sha256sum] = "c8058393dfa15f47e11ebd2f1d132693f0b3b3b8bf22d0201bfb305026f88a1b"
16
17PACKAGECONFIG ??= "\
18 ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)} \
19 ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'attr', '', d)} \
20"
21
22PACKAGECONFIG[acl] = "--with-acl,--without-acl,acl"
23PACKAGECONFIG[attr] = "--with-attr,--without-attr,attr"
24PACKAGECONFIG[libaio] = "--with-libaio,--without-libaio,libaio"
25PACKAGECONFIG[libbsd] = "--with-libbsd,--without-libbsd,libbsd"
26PACKAGECONFIG[libcap] = "--with-libcap,--without-libcap,libcap"
27PACKAGECONFIG[valgrind] = "--with-valgrind,--without-valgrind,valgrind"
28
29S = "${WORKDIR}/tdb-${PV}"
30
31inherit waf-samba
32
33#cross_compile cannot use preforked process, since fork process earlier than point subproces.popen
34#to cross Popen
35export WAF_NO_PREFORK="yes"
36
37EXTRA_OECONF += "--disable-rpath \
38 --bundled-libraries=NONE \
39 --builtin-libraries=replace \
40 --with-libiconv=${STAGING_DIR_HOST}${prefix}\
41 "
42
Andrew Geissler82c905d2020-04-13 13:39:40 -050043PACKAGES += "tdb-tools python3-tdb"
44
Patrick Williams213cb262021-08-07 19:21:33 -050045RPROVIDES:${PN}-dbg += "python3-tdb-dbg"
Andrew Geissler82c905d2020-04-13 13:39:40 -050046
Patrick Williams213cb262021-08-07 19:21:33 -050047FILES:${PN} = "${libdir}/*.so.*"
48FILES:tdb-tools = "${bindir}/*"
49FILES:python3-tdb = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/*"
50RDEPENDS:python3-tdb = "python3"
51INSANE_SKIP:${MLPREFIX}python3-tdb = "dev-so"