blob: 3d4f549b62e56423ae07953a1d4670a6435f8d76 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Cap'n Proto serialization/RPC system"
2DESCRIPTION = "Cap’n Proto is an insanely fast data interchange format and capability-based RPC system. "
3HOMEPAGE = "https://github.com/sandstorm-io/capnproto"
4SECTION = "console/tools"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://../LICENSE;md5=a05663ae6cca874123bf667a60dca8c9"
7
8SRC_URI = "git://github.com/sandstorm-io/capnproto.git;branch=release-${PV};protocol=https \
9 "
Andrew Geissler615f2f12022-07-15 14:00:58 -050010SRCREV = "2e88221d3dde22266bfccf40eaee6ff9b40d113d"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000011
12S = "${WORKDIR}/git/c++"
13
14inherit cmake
15
16CXXFLAGS:append:mips = " -latomic"
Andrew Geissler9aee5002022-03-30 16:27:02 +000017CXXFLAGS:append:powerpc = " -latomic"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000018CXXFLAGS:append:riscv32 = " -latomic"
19
20EXTRA_OECMAKE += "\
21 -DBUILD_TESTING=OFF \
22"
23
24FILES:${PN}-compiler = "${bindir}"
25
26PACKAGE_BEFORE_PN = "${PN}-compiler"
27RDEPENDS:${PN}-dev += "${PN}-compiler"
28
29BBCLASSEXTEND = "native nativesdk"