blob: e6fed584f9388ec2aa65ebcf15ff377d30b857a3 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Portable Hardware Locality (hwloc) software package"
2DESCRIPTION = "The Portable Hardware Locality (hwloc) software package \
3 provides a portable abstraction of the hierarchical topology of modern \
4 architectures."
5HOMEPAGE = "https://www.open-mpi.org/software/hwloc/"
6SECTION = "base"
Brad Bishop2d39a062019-10-28 08:33:36 -04007LICENSE = "BSD-3-Clause"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08008LIC_FILES_CHKSUM = "file://COPYING;md5=3282e20dc3cec311deda3c6d4b1f990b"
9
10SRC_URI = "https://www.open-mpi.org/software/${BPN}/v1.11/downloads/${BP}.tar.bz2"
Brad Bishop26bdd442019-08-16 17:08:17 -040011SRC_URI[md5sum] = "3c792e23c209e9e1bafe9bdbc613d401"
12SRC_URI[sha256sum] = "a4494b7765f517c0990d1c7f09d98cb87755bb6b841e4e2cbfebca1b14bac9c8"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013
14UPSTREAM_CHECK_URI = "https://www.open-mpi.org/software/hwloc/v1.11/"
15
16inherit autotools pkgconfig
17
18DEPENDS += "ncurses udev zlib"
19DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'libselinux', '', d)}"
20
21PACKAGECONFIG ?= "pci libxml2 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}"
22
23PACKAGECONFIG[numactl] = "--enable-libnuma,--disable-libnuma,numactl,numactl"
24PACKAGECONFIG[libxml2] = "--enable-libxml2,--disable-libxml2,libxml2,libxml2"
25PACKAGECONFIG[x11] = "--with-x,--without-x,virtual/libx11 cairo,cairo"
26PACKAGECONFIG[pci] = "--enable-pci,--disable-pci,libpciaccess,libpciaccess"
27
28# Split hwloc library into separate subpackage
Patrick Williams213cb262021-08-07 19:21:33 -050029PACKAGES:prepend = " libhwloc "
30FILES:libhwloc += "${libdir}/libhwloc.so.*"
31RDEPENDS:${PN} += "libhwloc (= ${EXTENDPKGV})"