blob: 0776ea2f62afa3cd7dbd31a90935e55d3d310131 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Opensource Implementation of WS-Management"
2DESCRIPTION = "Openwsman is a project intended to provide an open-source \
3implementation of the Web Services Management specipication \
4(WS-Management) and to expose system management information on the \
5Linux operating system using the WS-Management protocol. WS-Management \
6is based on a suite of web services specifications and usage \
7requirements that exposes a set of operations focused on and covers \
8all system management aspects. \
9Openwsman Server and service libraries"
10HOMEPAGE = "http://www.openwsman.org/"
11SECTION = "Applications/System"
12
13DEPENDS = "curl libxml2 openssl libpam"
14
Brad Bishop8410d612019-11-25 09:40:59 -050015inherit features_check
Brad Bishopc342db32019-05-15 21:57:59 -040016REQUIRED_DISTRO_FEATURES = "pam"
17
Patrick Williams03907ee2022-05-01 06:28:52 -050018SRCREV = "6cdf3bee50388d8e5f70850322a4df57fd685a5e"
Brad Bishopc342db32019-05-15 21:57:59 -040019
Patrick Williams7784c422022-11-17 07:29:11 -060020SRC_URI = "git://github.com/Openwsman/openwsman.git;branch=main;protocol=https \
Brad Bishopc342db32019-05-15 21:57:59 -040021 file://libssl-is-required-if-eventint-supported.patch \
22 file://openwsmand.service \
23 file://0001-lock.c-Define-PTHREAD_MUTEX_RECURSIVE_NP-if-undefine.patch \
24 "
25
26S = "${WORKDIR}/git"
27
Brad Bishop2d39a062019-10-28 08:33:36 -040028LICENSE = "BSD-3-Clause"
Brad Bishopc342db32019-05-15 21:57:59 -040029LIC_FILES_CHKSUM = "file://COPYING;md5=d4f53d4c6cf73b9d43186ce3be6dd0ba"
30
31inherit systemd cmake pkgconfig python3native perlnative
32
Patrick Williams213cb262021-08-07 19:21:33 -050033SYSTEMD_SERVICE:${PN} = "openwsmand.service"
Brad Bishopc342db32019-05-15 21:57:59 -040034SYSTEMD_AUTO_ENABLE = "disable"
35
Patrick Williams213cb262021-08-07 19:21:33 -050036LDFLAGS:append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', " -fuse-ld=bfd ", '', d)}"
Brad Bishopc342db32019-05-15 21:57:59 -040037
38EXTRA_OECMAKE = "-DBUILD_BINDINGS=NO \
39 -DBUILD_LIBCIM=NO \
40 -DBUILD_PERL=YES \
41 -DBUILD_PYTHON3=YES \
42 -DBUILD_PYTHON=NO \
43 -DCMAKE_INSTALL_PREFIX=${prefix} \
44 -DLIB=${baselib} \
45 "
46
Patrick Williams213cb262021-08-07 19:21:33 -050047do_configure:prepend() {
Brad Bishopc342db32019-05-15 21:57:59 -040048 export STAGING_INCDIR=${STAGING_INCDIR}
49 export STAGING_LIBDIR=${STAGING_LIBDIR}
50}
51
Patrick Williams213cb262021-08-07 19:21:33 -050052do_install:append() {
Brad Bishopc342db32019-05-15 21:57:59 -040053 install -d ${D}/${sysconfdir}/init.d
54 install -m 755 ${B}/etc/init/openwsmand.sh ${D}/${sysconfdir}/init.d/openwsmand
55 ln -sf ${sysconfdir}/init.d/openwsmand ${D}/${sbindir}/rcopenwsmand
56 chmod 755 ${D}/${sysconfdir}/openwsman/owsmangencert.sh
57 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
58 install -d ${D}/${systemd_unitdir}/system
59 install -m 644 ${WORKDIR}/openwsmand.service ${D}/${systemd_unitdir}/system
60
61 sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/openwsmand.service
62 sed -i -e 's,@SYSCONFDIR@,${sysconfdir},g' ${D}${systemd_unitdir}/system/openwsmand.service
63 sed -i -e 's,@LOCALSTATEDIR@,${localstatedir},g' ${D}${systemd_unitdir}/system/openwsmand.service
64 fi
65}
66
Patrick Williams213cb262021-08-07 19:21:33 -050067FILES:${PN}-dbg += "${libdir}/openwsman/plugins/.debug/ \
Brad Bishopc342db32019-05-15 21:57:59 -040068 ${libdir}/openwsman/authenticators/.debug/ \
69 "
70
Patrick Williams213cb262021-08-07 19:21:33 -050071INSANE_SKIP:${PN} = "dev-so"
72RDEPENDS:${PN} = "ruby"