blob: 62eceb2c0982d13766e2413e8d749cb06fb5bc6d [file] [log] [blame]
Andrew Geissler615f2f12022-07-15 14:00:58 -05001SUMMARY = "Python interface to PROJ (cartographic projections and coordinate transformations library)"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=dc4bb2668871655e24030dfe8d2a7ce7"
4DEPENDS = "python3-cython proj"
5DEPENDS:append:class-target = " python3-cython-native proj-native"
6
7PYPI_PACKAGE = "pyproj"
8
9inherit pypi setuptools3
10
Andrew Geissler87f5cff2022-09-30 13:13:31 -050011SRC_URI[sha256sum] = "a708445927ace9857f52c3ba67d2915da7b41a8fdcd9b8f99a4c9ed60a75eb33"
Andrew Geissler615f2f12022-07-15 14:00:58 -050012
13RDEPENDS:${PN} = "${PYTHON_PN}-certifi proj"
14
15export PROJ_INCDIR = "${STAGING_INCDIR}"
16export PROJ_LIBDIR = "${STAGING_LIBDIR}"