blob: b8598af639f88bbb7d9f6293f7649784a73fa8aa [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "a fast C/C++ compiler cache"
2DESCRIPTION = "ccache is a compiler cache. It speeds up recompilation \
3by caching the result of previous compilations and detecting when the \
4same compilation is being done again. Supported languages are C, C\+\+, \
5Objective-C and Objective-C++."
6HOMEPAGE = "http://ccache.samba.org"
7SECTION = "devel"
8
9LICENSE = "GPL-3.0-or-later"
Patrick Williams7784c422022-11-17 07:29:11 -060010LIC_FILES_CHKSUM = "file://LICENSE.adoc;md5=8fc2cae2bbabeb9236cacfa1c83a3dc5"
Patrick Williams92b42cb2022-09-03 06:53:57 -050011
12DEPENDS = "zstd"
13
Andrew Geissler87f5cff2022-09-30 13:13:31 -050014SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/${BP}.tar.gz \
Patrick Williams92b42cb2022-09-03 06:53:57 -050015 file://0001-xxhash.h-Fix-build-with-gcc-12.patch \
Andrew Geissler87f5cff2022-09-30 13:13:31 -050016 "
Patrick Williams7784c422022-11-17 07:29:11 -060017SRC_URI[sha256sum] = "6b346f441342a25a6c1d7e010957a593f416e94b5d66fdf2e2992953b3860b9d"
Patrick Williams92b42cb2022-09-03 06:53:57 -050018
Andrew Geissler87f5cff2022-09-30 13:13:31 -050019inherit cmake github-releases
Patrick Williams92b42cb2022-09-03 06:53:57 -050020
21PATCHTOOL = "patch"
22
23BBCLASSEXTEND = "native nativesdk"
24
25PACKAGECONFIG[docs] = "-DENABLE_DOCUMENTATION=ON,-DENABLE_DOCUMENTATION=OFF,asciidoc"
26PACKAGECONFIG[redis] = "-DREDIS_STORAGE_BACKEND=ON,-DREDIS_STORAGE_BACKEND=OFF,hiredis"