blob: a47488909931714fd6c839d0edfd50b70ab171b3 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "jQuery is a fast, small, and feature-rich JavaScript library"
2HOMEPAGE = "https://jquery.com/"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06003DESCRIPTION = "${SUMMARY}"
Andrew Geissler82c905d2020-04-13 13:39:40 -05004LICENSE = "MIT"
5SECTION = "devel"
Andrew Geissler95ac1b82021-03-31 14:34:31 -05006LIC_FILES_CHKSUM = "file://${S}/${BP}.js;beginline=8;endline=10;md5=9c7c6e9ab275fc1e0d99cb7180ecd14c"
Andrew Geissler82c905d2020-04-13 13:39:40 -05007
Andrew Geissler475cb722020-07-10 16:00:51 -05008# unpack items to ${S} so the archiver can see them
9#
Andrew Geissler82c905d2020-04-13 13:39:40 -050010SRC_URI = "\
Andrew Geissler475cb722020-07-10 16:00:51 -050011 https://code.jquery.com/${BP}.js;name=js;subdir=${BP} \
12 https://code.jquery.com/${BP}.min.js;name=min;subdir=${BP} \
13 https://code.jquery.com/${BP}.min.map;name=map;subdir=${BP} \
Andrew Geissler82c905d2020-04-13 13:39:40 -050014 "
15
Patrick Williams2390b1b2022-11-03 13:47:49 -050016SRC_URI[js.sha256sum] = "df3941e6cdaec28533ad72b7053ec05f7172be88ecada345c42736bc2ffba4d2"
17SRC_URI[min.sha256sum] = "a3cf00c109d907e543bc4f6dbc85eb31068f94515251347e9e57509b52ee3d74"
18SRC_URI[map.sha256sum] = "856ee620cebac56e872d6e99b09de05f81ccd3f3dc346e9b55eb694611a6d5e1"
Andrew Geissler82c905d2020-04-13 13:39:40 -050019
20UPSTREAM_CHECK_REGEX = "jquery-(?P<pver>\d+(\.\d+)+)\.js"
21
William A. Kennington IIIac69b482021-06-02 12:28:27 -070022# https://github.com/jquery/jquery/issues/3927
23# There are ways jquery can expose security issues but any issues are in the apps exposing them
24# and there is little we can directly do
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000025CVE_CHECK_IGNORE += "CVE-2007-2379"
William A. Kennington IIIac69b482021-06-02 12:28:27 -070026
Andrew Geissler82c905d2020-04-13 13:39:40 -050027inherit allarch
28
29do_install() {
30 install -d ${D}${datadir}/javascript/${BPN}/
Andrew Geissler475cb722020-07-10 16:00:51 -050031 install -m 644 ${S}/${BP}.js ${D}${datadir}/javascript/${BPN}/${BPN}.js
32 install -m 644 ${S}/${BP}.min.js ${D}${datadir}/javascript/${BPN}/${BPN}.min.js
33 install -m 644 ${S}/${BP}.min.map ${D}${datadir}/javascript/${BPN}/${BPN}.min.map
Andrew Geissler82c905d2020-04-13 13:39:40 -050034}
35
36PACKAGES = "${PN}"
Patrick Williams213cb262021-08-07 19:21:33 -050037FILES:${PN} = "${datadir}"
Andrew Geissler82c905d2020-04-13 13:39:40 -050038
39BBCLASSEXTEND += "native nativesdk"