blob: 46cfce53ff6da9ad6fc3d028ae6d5882abde83ee [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "A library providing C and Python (libcURL like) API \
2 for downloading linux repository metadata and packages."
3HOMEPAGE = "https://github.com/rpm-software-management/librepo"
4DESCRIPTION = "${SUMMARY}"
5LICENSE = "LGPL-2.1-only"
6LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
7
8SRC_URI = "git://github.com/rpm-software-management/librepo.git;branch=master;protocol=https \
9 file://0002-Do-not-try-to-obtain-PYTHON_INSTALL_DIR-by-running-p.patch \
10 file://0004-Set-gpgme-variables-with-pkg-config-not-with-cmake-m.patch \
Patrick Williams92b42cb2022-09-03 06:53:57 -050011 "
12
Andrew Geissler87f5cff2022-09-30 13:13:31 -050013SRCREV = "f4b915be5e04e88263097f65addfcac5919fef41"
Patrick Williams92b42cb2022-09-03 06:53:57 -050014
15S = "${WORKDIR}/git"
16
17DEPENDS = "curl glib-2.0 openssl attr gpgme libxml2"
18
19inherit cmake setuptools3-base pkgconfig
20
21EXTRA_OECMAKE = " \
22 -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} \
23 -DPYTHON_DESIRED=3 \
24 -DENABLE_TESTS=OFF \
25 -DENABLE_DOCS=OFF \
26 -DWITH_ZCHUNK=OFF \
27"
28
29BBCLASSEXTEND = "native nativesdk"