blob: 07bbafa81fbfe1c15d1a3dfe9e6de9646c48fb31 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Library and tool for installing Python wheels"
2DESCRIPTION = "A low-level library for installing a Python package from a wheel distribution."
3HOMEPAGE = "https://installer.readthedocs.io/"
4BUGTRACKER = "https://github.com/pypa/installer/issues"
5
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=5038641aec7a77451e31da828ebfae00"
8
9SRC_URI += "file://interpreter.patch"
10
11SRC_URI[sha256sum] = "f970995ec2bb815e2fdaf7977b26b2091e1e386f0f42eafd5ac811953dc5d445"
12
13inherit pypi python_flit_core
14
Andrew Geissler615f2f12022-07-15 14:00:58 -050015# Bootstrap the native build
16DEPENDS:remove:class-native = "python3-picobuild-native python3-installer-native"
Andrew Geissler9aee5002022-03-30 16:27:02 +000017
Andrew Geissler615f2f12022-07-15 14:00:58 -050018INSTALL_WHEEL_COMPILE_BYTECODE:class-native = "--no-compile-bytecode"
19
20do_compile:class-native () {
21 python_flit_core_do_manual_build
22}
23
24do_install:prepend:class-native() {
25 export PYTHONPATH="${S}/src"
Andrew Geissler9aee5002022-03-30 16:27:02 +000026}
27
28BBCLASSEXTEND = "native nativesdk"