blob: b231f8b34d744157eb75ab0c3408e3d36e6dcce6 [file] [log] [blame]
Brad Bishop08902b02019-08-20 09:16:51 -04001SUMMARY = "Xlib: Compose data files for libx11"
2DESCRIPTION = "This package provides the compose data files for libx11."
3
4python () {
5 if bb.utils.contains('DISTRO_FEATURES', 'x11', True, False, d):
6 raise bb.parse.SkipRecipe("libx11-compose-data is incompatible with x11 distro feature, use libx11 instead.")
7}
8
9require xorg-lib-common.inc
10
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000011LICENSE = "MIT & MIT & BSD-1-Clause & HPND & HPND-sell-variant"
Brad Bishop08902b02019-08-20 09:16:51 -040012LIC_FILES_CHKSUM = "file://COPYING;md5=172255dee66bb0151435b2d5d709fcf7"
13
14SRC_URI[md5sum] = "c5fa5a86a20e3591bed6c046498d4b8f"
15SRC_URI[sha256sum] = "b289a845c189e251e0e884cc0f9269bbe97c238df3741e854ec4c17c21e473d5"
16
Andrew Geissler82c905d2020-04-13 13:39:40 -050017SRC_URI += "file://0001-Drop-x11-dependencies.patch \
Andrew Geisslerd1e89492021-02-12 15:35:20 -060018 "
Brad Bishop08902b02019-08-20 09:16:51 -040019
20XORG_PN = "libX11"
21
22EXTRA_OECONF += "--disable-xkb"
23
24PACKAGES = "${PN}"
25
Patrick Williams213cb262021-08-07 19:21:33 -050026FILES:${PN} = "${datadir}/X11/locale ${libdir}/X11/locale"
Brad Bishop08902b02019-08-20 09:16:51 -040027
28do_compile() {
29 oe_runmake -C nls
30}
31
32do_install() {
33 oe_runmake DESTDIR=${D} -C nls install
34}
35
36REQUIRED_DISTRO_FEATURES = ""