blob: 66311b2edf1440a44d89a533ce65a70e4ca26fee [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "HTTP/2 C Library and tools"
2HOMEPAGE = "https://nghttp2.org/"
3SECTION = "libs"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=764abdf30b2eadd37ce47dcbce0ea1ec"
6
Andrew Geissler9aee5002022-03-30 16:27:02 +00007SRC_URI = "\
Andrew Geissler87f5cff2022-09-30 13:13:31 -05008 ${GITHUB_BASE_URI}/download/v${PV}/nghttp2-${PV}.tar.xz \
Andrew Geissler9aee5002022-03-30 16:27:02 +00009 file://0001-fetch-ocsp-response-use-python3.patch \
10"
Patrick Williams7784c422022-11-17 07:29:11 -060011SRC_URI[sha256sum] = "af24007e34c18c782393a1dc3685f8fd5b50283e90a9191d25488eb50aa2c825"
Andrew Geissler9aee5002022-03-30 16:27:02 +000012
Andrew Geissler87f5cff2022-09-30 13:13:31 -050013inherit cmake manpages python3native github-releases
Andrew Geissler9aee5002022-03-30 16:27:02 +000014PACKAGECONFIG[manpages] = ""
15
16# examples are never installed, and don't need to be built in the
17# first place
18EXTRA_OECMAKE = "-DENABLE_EXAMPLES=OFF -DENABLE_APP=OFF -DENABLE_HPACK_TOOLS=OFF"
19
20PACKAGES =+ "lib${BPN} ${PN}-client ${PN}-proxy ${PN}-server"
21
22RDEPENDS:${PN} = "${PN}-client (>= ${PV}) ${PN}-proxy (>= ${PV}) ${PN}-server (>= ${PV})"
23RDEPENDS:${PN}:class-native = ""
24RDEPENDS:${PN}-proxy = "openssl python3-core python3-io python3-shell"
25
26ALLOW_EMPTY:${PN} = "1"
27FILES:${PN} = ""
28FILES:lib${BPN} = "${libdir}/*${SOLIBS}"
29FILES:${PN}-client = "${bindir}/h2load ${bindir}/nghttp"
30FILES:${PN}-proxy = "${bindir}/nghttpx ${datadir}/${BPN}/fetch-ocsp-response"
31FILES:${PN}-server = "${bindir}/nghttpd"
32
33BBCLASSEXTEND = "native nativesdk"