blob: fd478b216129aa298a6daca54a8d24bd51d38dba [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001HOMEPAGE = "http://mesonbuild.com"
2SUMMARY = "A high performance build system"
3DESCRIPTION = "Meson is a build system designed to increase programmer \
4productivity. It does this by providing a fast, simple and easy to use \
5interface for modern software development tools and practices."
6
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
9
10GITHUB_BASE_URI = "https://github.com/mesonbuild/meson/releases/"
11SRC_URI = "${GITHUB_BASE_URI}/download/${PV}/meson-${PV}.tar.gz \
12 file://meson-setup.py \
13 file://meson-wrapper \
14 file://0001-python-module-do-not-manipulate-the-environment-when.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060015 file://0001-Make-CPU-family-warnings-fatal.patch \
16 file://0002-Support-building-allarch-recipes-again.patch \
17 file://0001-Check-for-clang-before-guessing-gcc-or-lcc.patch \
18 "
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050019SRC_URI[sha256sum] = "d926b730de6f518728cc7c57bc5e701667bae0c3522f9e369427b2cc7839d3c1"
Andrew Geissler517393d2023-01-13 08:55:19 -060020
21inherit python_setuptools_build_meta github-releases
22
23RDEPENDS:${PN} = "ninja python3-modules python3-pkg-resources"
24
25FILES:${PN} += "${datadir}/polkit-1"
26
27do_install:append () {
28 # As per the same issue in the python recipe itself:
29 # Unfortunately the following pyc files are non-deterministc due to 'frozenset'
30 # being written without strict ordering, even with PYTHONHASHSEED = 0
31 # Upstream is discussing ways to solve the issue properly, until then let's
32 # just not install the problematic files.
33 # More info: http://benno.id.au/blog/2013/01/15/python-determinism
34 rm ${D}${libdir}/python*/site-packages/mesonbuild/dependencies/__pycache__/mpi.cpython*
35}
36
37BBCLASSEXTEND = "native nativesdk"
38
39inherit meson-routines
40
41# The cross file logic is similar but not identical to that in meson.bbclass,
42# since it's generating for an SDK rather than a cross-compile. Important
43# differences are:
44# - We can't set vars like CC, CXX, etc. yet because they will be filled in with
45# real paths by meson-setup.sh when the SDK is extracted.
46# - Some overrides aren't needed, since the SDK injects paths that take care of
47# them.
48def var_list2str(var, d):
49 items = d.getVar(var).split()
50 return items[0] if len(items) == 1 else ', '.join(repr(s) for s in items)
51
52def generate_native_link_template(d):
53 val = ['-L@{OECORE_NATIVE_SYSROOT}${libdir_native}',
54 '-L@{OECORE_NATIVE_SYSROOT}${base_libdir_native}',
55 '-Wl,-rpath-link,@{OECORE_NATIVE_SYSROOT}${libdir_native}',
56 '-Wl,-rpath-link,@{OECORE_NATIVE_SYSROOT}${base_libdir_native}',
57 '-Wl,--allow-shlib-undefined'
58 ]
59 build_arch = d.getVar('BUILD_ARCH')
60 if 'x86_64' in build_arch:
61 loader = 'ld-linux-x86-64.so.2'
62 elif 'i686' in build_arch:
63 loader = 'ld-linux.so.2'
64 elif 'aarch64' in build_arch:
65 loader = 'ld-linux-aarch64.so.1'
66 elif 'ppc64le' in build_arch:
67 loader = 'ld64.so.2'
Patrick Williams864cc432023-02-09 14:54:44 -060068 elif 'loongarch64' in build_arch:
69 loader = 'ld-linux-loongarch-lp64d.so.1'
Andrew Geissler517393d2023-01-13 08:55:19 -060070
71 if loader:
72 val += ['-Wl,--dynamic-linker=@{OECORE_NATIVE_SYSROOT}${base_libdir_native}/' + loader]
73
74 return repr(val)
75
76install_templates() {
77 install -d ${D}${datadir}/meson
78
79 cat >${D}${datadir}/meson/meson.native.template <<EOF
80[binaries]
81c = ${@meson_array('BUILD_CC', d)}
82cpp = ${@meson_array('BUILD_CXX', d)}
83ar = ${@meson_array('BUILD_AR', d)}
84nm = ${@meson_array('BUILD_NM', d)}
85strip = ${@meson_array('BUILD_STRIP', d)}
86readelf = ${@meson_array('BUILD_READELF', d)}
87pkgconfig = 'pkg-config-native'
88
89[built-in options]
90c_args = ['-isystem@{OECORE_NATIVE_SYSROOT}${includedir_native}' , ${@var_list2str('BUILD_OPTIMIZATION', d)}]
91c_link_args = ${@generate_native_link_template(d)}
92cpp_args = ['-isystem@{OECORE_NATIVE_SYSROOT}${includedir_native}' , ${@var_list2str('BUILD_OPTIMIZATION', d)}]
93cpp_link_args = ${@generate_native_link_template(d)}
94[properties]
95sys_root = '@OECORE_NATIVE_SYSROOT'
96EOF
97
98 cat >${D}${datadir}/meson/meson.cross.template <<EOF
99[binaries]
100c = @CC
101cpp = @CXX
102ar = @AR
103nm = @NM
104strip = @STRIP
105pkgconfig = 'pkg-config'
106
107[built-in options]
108c_args = @CFLAGS
109c_link_args = @LDFLAGS
110cpp_args = @CPPFLAGS
111cpp_link_args = @LDFLAGS
112
113[properties]
114needs_exe_wrapper = true
115sys_root = @OECORE_TARGET_SYSROOT
116
117[host_machine]
118system = '$host_system'
119cpu_family = '$host_cpu_family'
120cpu = '$host_cpu'
121endian = '$host_endian'
122EOF
123}
124
125do_install:append:class-nativesdk() {
126 host_system=${SDK_OS}
127 host_cpu_family=${@meson_cpu_family("SDK_ARCH", d)}
128 host_cpu=${SDK_ARCH}
129 host_endian=${@meson_endian("SDK", d)}
130 install_templates
131
132 install -d ${D}${SDKPATHNATIVE}/post-relocate-setup.d
133 install -m 0755 ${WORKDIR}/meson-setup.py ${D}${SDKPATHNATIVE}/post-relocate-setup.d/
134
135 # We need to wrap the real meson with a thin env setup wrapper.
136 mv ${D}${bindir}/meson ${D}${bindir}/meson.real
137 install -m 0755 ${WORKDIR}/meson-wrapper ${D}${bindir}/meson
138}
139
140FILES:${PN}:append:class-nativesdk = "${datadir}/meson ${SDKPATHNATIVE}"
141
142do_install:append:class-native() {
143 host_system=${HOST_OS}
144 host_cpu_family=${@meson_cpu_family("HOST_ARCH", d)}
145 host_cpu=${HOST_ARCH}
146 host_endian=${@meson_endian("HOST", d)}
147 install_templates
148
149 install -d ${D}${datadir}/post-relocate-setup.d
150 install -m 0755 ${WORKDIR}/meson-setup.py ${D}${datadir}/post-relocate-setup.d/
151
152 # We need to wrap the real meson with a thin wrapper that substitues native/cross files
153 # when running in a direct SDK environment.
154 mv ${D}${bindir}/meson ${D}${bindir}/meson.real
155 install -m 0755 ${WORKDIR}/meson-wrapper ${D}${bindir}/meson
156}