blob: 87c997047f8a3a33475031ee970451e8a1788072 [file] [log] [blame]
Adriana Kobylak15a8b0e2020-06-02 13:18:36 -05001SUMMARY = "Miscellaneous OpenBMC functions"
2HOMEPAGE = "https://github.com/openbmc/phosphor-misc"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
5PR = "r1"
6PV = "1.0+git${SRCPV}"
7
Patrick Williamsbb99d222022-01-24 15:55:09 -06008SRC_URI = "git://github.com/openbmc/phosphor-misc;branch=master;protocol=https"
Andrew Geissler573093b2022-08-19 09:20:59 -05009SRCREV = "8ae2fcd1cad309c607671dd83a94aa13cc2fbdc6"
Adriana Kobylak15a8b0e2020-06-02 13:18:36 -050010
11S = "${WORKDIR}/git"
12
13inherit meson
14inherit pkgconfig
15inherit systemd
16
17DEPENDS = "systemd"
18
19PHOSPHOR_MISC_PACKAGES = " \
20 ${@bb.utils.contains('PACKAGECONFIG', 'first-boot-set-hostname', '${PN}-first-boot-set-hostname', '', d)} \
21 ${@bb.utils.contains('PACKAGECONFIG', 'first-boot-set-mac', '${PN}-first-boot-set-mac', '', d)} \
22 ${@bb.utils.contains('PACKAGECONFIG', 'http-redirect-awk', '${PN}-http-redirect-awk', '', d)} \
23 ${@bb.utils.contains('PACKAGECONFIG', 'usb-ctrl', '${PN}-usb-ctrl', '', d)} \
24 "
25
Wang Xiaohuad8310602022-07-29 17:45:24 +080026PACKAGES = "${PHOSPHOR_MISC_PACKAGES}"
Adriana Kobylak15a8b0e2020-06-02 13:18:36 -050027PACKAGE_BEFORE_PN += "${PHOSPHOR_MISC_PACKAGES}"
28SYSTEMD_PACKAGES = "${PHOSPHOR_MISC_PACKAGES}"
29
30PACKAGECONFIG ??= " \
31 first-boot-set-hostname \
32 first-boot-set-mac \
33 http-redirect-awk \
34 usb-ctrl \
35 "
36
37PACKAGECONFIG[first-boot-set-hostname] = "-Dfirst-boot-set-hostname=enabled, -Dfirst-boot-set-hostname=disabled"
38PACKAGECONFIG[first-boot-set-mac] = "-Dfirst-boot-set-mac=enabled, -Dfirst-boot-set-mac=disabled"
39PACKAGECONFIG[http-redirect-awk] = "-Dhttp-redirect=enabled, -Dhttp-redirect=disabled"
40PACKAGECONFIG[usb-ctrl] = "-Dusb-ctrl=enabled, -Dusb-ctrl=disabled"
41
42# first-boot-set-hostname
Patrick Williams12fc9392021-08-06 09:16:53 -050043FILES:${PN}-first-boot-set-hostname = "${bindir}/first-boot-set-hostname.sh"
44SYSTEMD_SERVICE:${PN}-first-boot-set-hostname = "first-boot-set-hostname.service"
Adriana Kobylak15a8b0e2020-06-02 13:18:36 -050045
46# first-boot-set-mac
Patrick Williams12fc9392021-08-06 09:16:53 -050047FILES:${PN}-first-boot-set-mac = "${bindir}/first-boot-set-mac.sh"
48SYSTEMD_SERVICE:${PN}-first-boot-set-mac = "first-boot-set-mac@.service"
Adriana Kobylak15a8b0e2020-06-02 13:18:36 -050049
50# http-redirect-awk
Patrick Williams12fc9392021-08-06 09:16:53 -050051FILES:${PN}-http-redirect-awk = "${bindir}/http-redirect.awk"
52SYSTEMD_SERVICE:${PN}-http-redirect-awk = " \
Adriana Kobylak15a8b0e2020-06-02 13:18:36 -050053 http-redirect@.service \
54 http-redirect.socket \
55 "
Patrick Williams12fc9392021-08-06 09:16:53 -050056RDEPENDS:${PN}-http-redirect-awk = "${VIRTUAL-RUNTIME_base-utils}"
Adriana Kobylak15a8b0e2020-06-02 13:18:36 -050057
58# usb-ctrl
Patrick Williams12fc9392021-08-06 09:16:53 -050059FILES:${PN}-usb-ctrl = "${bindir}/usb-ctrl"