blob: 658dc0beec311e5d02052c33388b9e02dbcebf23 [file] [log] [blame]
Patrick Williams12fc9392021-08-06 09:16:53 -05001FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
Brad Bishopf61a81a2019-02-04 14:28:33 -05002
3SRC_URI += " file://pam.d/common-password \
4 file://pam.d/common-account \
5 file://pam.d/common-auth \
Richard Marian Thomaiyar2b597052019-11-02 21:24:29 +05306 file://pam.d/common-session \
Brad Bishopf61a81a2019-02-04 14:28:33 -05007 "
8
Patrick Williams12fc9392021-08-06 09:16:53 -05009do_install:append() {
Matt Spinler31ab8e72018-10-16 11:32:13 -050010 # The libpam recipe will always add a pam_systemd.so line to
11 # common-session if systemd is enabled; however systemd only
12 # builds pam_systemd.so if logind is enabled, and we disable
13 # that package. So, remove the pam_systemd.so line here.
14 sed -i '/pam_systemd.so/d' ${D}${sysconfdir}/pam.d/common-session
15}
Ed Tanous9936f862022-09-19 09:13:20 -070016
17RDEPENDS:${PN}-runtime += "${MLPREFIX}pam-plugin-cracklib-${libpam_suffix} \
18 ${MLPREFIX}pam-plugin-tally2-${libpam_suffix} \
19 ${MLPREFIX}pam-plugin-pwhistory-${libpam_suffix} \
20 ${MLPREFIX}pam-plugin-succeed-if-${libpam_suffix} \
21 ${MLPREFIX}pam-plugin-localuser-${libpam_suffix} \
22 "