blob: 093457e34f13b8ef0d27f03e3923c16273b24729 [file] [log] [blame]
Ed Tanous9936f862022-09-19 09:13:20 -07001# To add additional config files, create a recipe in your layer,
2# and add it to PHOSPHOR_DBUS_MONITOR_CONFIGS with a bbappend to this recipe.
Matthew Barthbd02cf92019-06-12 16:17:38 -05003SUMMARY = "Phosphor DBus Monitor Configuration"
4DESCRIPTION = "Meta-recipe, pulling in non-native recipes that wish to add \
5configuration files to the /usr/share/phosphor-dbus-monitor filesystem."
6HOMEPAGE = "http://github.com/openbmc/phosphor-dbus-monitor"
Matthew Barthbd02cf92019-06-12 16:17:38 -05007LICENSE = "Apache-2.0"
Brad Bishop6f3f0aa2019-09-13 12:14:05 -04008LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Ed Tanous9936f862022-09-19 09:13:20 -07009DEPENDS += "${PHOSPHOR_DBUS_MONITOR_CONFIGS}"
10PR = "r1"
Matthew Barthbd02cf92019-06-12 16:17:38 -050011
12inherit phosphor-dbus-monitor
13
Matthew Barthbd02cf92019-06-12 16:17:38 -050014do_install() {
15 mkdir -p ${D}${config_dir}
16}
17
Patrick Williams12fc9392021-08-06 09:16:53 -050018FILES:${PN} += "${config_dir}"
Ed Tanous9936f862022-09-19 09:13:20 -070019
20PHOSPHOR_DBUS_MONITOR_CONFIGS ??= ""