blob: 10fb5d8d8726873fdd2bb56240557f6c039fb4a7 [file] [log] [blame]
Patrick Venture998ff012018-03-09 15:37:45 -08001# Each platform will need a service file that starts
2# at an appropriate time per system. For instance, if
3# your system relies on passive dbus for fans or other
4# sensors then it may be prudent to wait for all of them.
Ed Tanous9936f862022-09-19 09:13:20 -07005SUMMARY = "Phosphor PID Fan Control"
6DESCRIPTION = "Fan Control"
7HOMEPAGE = "github.com/openbmc/phosphor-pid-control"
8LICENSE = "Apache-2.0"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
Patrick Venture998ff012018-03-09 15:37:45 -080010DEPENDS += "autoconf-archive-native"
Patrick Venture998ff012018-03-09 15:37:45 -080011DEPENDS += "sdbusplus"
Brad Bishop44f3cce2019-03-22 23:41:42 -040012DEPENDS += "phosphor-dbus-interfaces"
Patrick Venture998ff012018-03-09 15:37:45 -080013DEPENDS += "phosphor-logging"
14DEPENDS += "libevdev"
Patrick Venture4686bb52019-02-12 08:59:31 -080015DEPENDS += "nlohmann-json"
Patrick Venture0647c292019-03-11 08:45:12 -070016DEPENDS += "cli11"
Andrew Geissler3f2554c2019-04-15 14:22:02 +000017DEPENDS += "boost"
Patrick Venture998ff012018-03-09 15:37:45 -080018# We depend on this to be built first so we can build our providers.
19DEPENDS += "phosphor-ipmi-host"
Ed Tanous9936f862022-09-19 09:13:20 -070020SRCREV = "bcdeb83ca05ed0fa352290ec8f78bb28a2d1d2fb"
21PV = "0.1+git${SRCPV}"
22PR = "r1"
Patrick Venture998ff012018-03-09 15:37:45 -080023
Ed Tanous9936f862022-09-19 09:13:20 -070024SRC_URI = "git://github.com/openbmc/phosphor-pid-control;branch=master;protocol=https"
25
26S = "${WORKDIR}/git"
Vijay Khemka09ad25b2019-06-20 14:37:11 -070027SERVICE_FILE = "phosphor-pid-control.service"
28SYSTEMD_PACKAGES = "${PN}"
Patrick Williams12fc9392021-08-06 09:16:53 -050029SYSTEMD_SERVICE:${PN} = "${SERVICE_FILE}"
Vijay Khemka09ad25b2019-06-20 14:37:11 -070030
Ed Tanous9936f862022-09-19 09:13:20 -070031inherit autotools pkgconfig
32inherit obmc-phosphor-ipmiprovider-symlink
33inherit systemd
34
Vijay Khemka09ad25b2019-06-20 14:37:11 -070035EXTRA_OECONF = " \
36 SYSTEMD_TARGET="multi-user.target" \
William A. Kennington IIIb05134b2021-06-04 17:51:28 -070037 --disable-tests \
Vijay Khemka09ad25b2019-06-20 14:37:11 -070038 "
39
Patrick Williams12fc9392021-08-06 09:16:53 -050040FILES:${PN} = "${bindir}/swampd ${bindir}/setsensor"
Patrick Venture26f8c6c2018-07-27 07:27:01 -070041# The following installs the OEM IPMI handler for the fan controls.
Patrick Williams12fc9392021-08-06 09:16:53 -050042FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
43FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
44FILES:${PN}:append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
45FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
Patrick Venture998ff012018-03-09 15:37:45 -080046
Patrick Venture26f8c6c2018-07-27 07:27:01 -070047HOSTIPMI_PROVIDER_LIBRARY += "libmanualcmds.so"
Ed Tanous9936f862022-09-19 09:13:20 -070048config_datadir = "${datadir}/swampd/"
Brandon Kim627e5cd2020-08-13 14:51:02 -070049# config_path is the location swampd expects to find a json configuration.
50# the file is expected to be named config.json
Ed Tanous9936f862022-09-19 09:13:20 -070051config_path = "${config_datadir}config.json"