blob: 31a06284e2066df1fe13f0ef3cea162cd1396a7a [file] [log] [blame]
Adriana Kobylak81846a22020-07-12 15:12:36 -05001SUMMARY = "Provides a host firmware image"
2DESCRIPTION = "Use a bbappend to add the image files"
Ed Tanous9936f862022-09-19 09:13:20 -07003LICENSE = "${HOSTFW_LICENSE}"
4LIC_FILES_CHKSUM = "${HOSTFW_LIC_FILES_CHKSUM}"
Adriana Kobylak81846a22020-07-12 15:12:36 -05005PR = "r1"
6
7inherit allarch
8inherit deploy
9
Adriana Kobylakf717d452020-07-17 10:26:40 -050010do_compile() {
Adriana Kobylak81846a22020-07-12 15:12:36 -050011 # The image directory can be used as the source to create a filesystem to
12 # add to the BMC image.
13 install -d ${B}/image
Adriana Kobylak81846a22020-07-12 15:12:36 -050014 # Install an image-hostfw file in the update directory to be included in
15 # the code update tarball.
16 install -d ${B}/update
17}
18
Ed Tanous9936f862022-09-19 09:13:20 -070019addtask deploy before do_build after do_compile
20
21HOSTFW_LICENSE ?= "Apache-2.0"
22HOSTFW_LIC_FILES_CHKSUM ?= "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Adriana Kobylak81846a22020-07-12 15:12:36 -050023do_deploy() {
24 install -d ${DEPLOYDIR}/hostfw/image
25 install -d ${DEPLOYDIR}/hostfw/update
Adriana Kobylakf717d452020-07-17 10:26:40 -050026 cp -R --no-dereference --preserve=mode,links ${B}/image/ ${DEPLOYDIR}/hostfw/
27 cp -R --no-dereference --preserve=mode,links ${B}/update/ ${DEPLOYDIR}/hostfw/
Adriana Kobylak81846a22020-07-12 15:12:36 -050028}