blob: 54abc12e732a5c81bca6c6ce8dad38792705b3e8 [file] [log] [blame]
Matt Spinlerb640b0b2018-06-21 14:23:47 -05001SUMMARY = "Copy error yaml files to known path for elog parsing"
Matt Spinlerb640b0b2018-06-21 14:23:47 -05002LICENSE = "Apache-2.0"
Brad Bishop6f3f0aa2019-09-13 12:14:05 -04003LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Ed Tanous9936f862022-09-19 09:13:20 -07004PV = "1.0+git${SRCPV}"
5PR = "r1"
6
7S = "${WORKDIR}/git"
Matt Spinlerb640b0b2018-06-21 14:23:47 -05008
Matt Spinlerb640b0b2018-06-21 14:23:47 -05009inherit phosphor-dbus-yaml
Joseph Reynolds79809ea2021-02-26 15:37:31 -060010inherit native
Matt Spinlerb640b0b2018-06-21 14:23:47 -050011
Patrick Williams12fc9392021-08-06 09:16:53 -050012do_install:append() {
Matt Spinlerb640b0b2018-06-21 14:23:47 -050013 SRC=${S}/xyz/openbmc_project/Software/
14 DEST=${D}${yaml_dir}/xyz/openbmc_project/Software/
15 install -d ${DEST}
16 install ${SRC}/*.errors.yaml ${DEST}
17 install ${SRC}/*.metadata.yaml ${DEST}
18}
Ed Tanous9936f862022-09-19 09:13:20 -070019
20require phosphor-software-manager.inc