blob: 182c2061058f9e754c8df2e8449b4a70d993c8d6 [file] [log] [blame]
Deepak Kodihalli48be0fd2017-02-20 04:55:20 -06001SUMMARY = "FRU properties config for ipmi-fru-parser"
Brad Bishop75f03872018-11-03 09:41:57 -07002LICENSE = "Apache-2.0"
Brad Bishop6f3f0aa2019-09-13 12:14:05 -04003LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Ed Tanous9936f862022-09-19 09:13:20 -07004DEPENDS += " \
5 mrw-native \
6 mrw-perl-tools-native \
7 "
8PROVIDES += "virtual/phosphor-ipmi-fru-properties"
9PR = "r1"
10
11SRC_URI += "file://config.yaml"
12
13S = "${WORKDIR}"
Deepak Kodihalli48be0fd2017-02-20 04:55:20 -060014
Deepak Kodihalli48be0fd2017-02-20 04:55:20 -060015inherit phosphor-ipmi-fru
Matt Spinler0a8ea632017-12-14 13:31:55 -060016inherit mrw-xml
Joseph Reynolds79809ea2021-02-26 15:37:31 -060017inherit native
Deepak Kodihalli48be0fd2017-02-20 04:55:20 -060018
Deepak Kodihalli48be0fd2017-02-20 04:55:20 -060019do_install() {
20 DEST=${D}${properties_datadir}
21 install -d ${DEST}
Deepak Kodihalli48be0fd2017-02-20 04:55:20 -060022 ${bindir}/perl-native/perl \
23 ${bindir}/gen_fru_properties.pl \
Matt Spinler0a8ea632017-12-14 13:31:55 -060024 -m ${mrw_datadir}/${MRW_XML} \
Deepak Kodihalli48be0fd2017-02-20 04:55:20 -060025 -c config.yaml \
Ratan Gupta338899a2017-03-30 14:32:02 +053026 -o ${DEST}/extra-properties.yaml
Deepak Kodihalli48be0fd2017-02-20 04:55:20 -060027}