blob: f87f13a56bd80954bf4c8ca4ec583791f9f22d39 [file] [log] [blame]
Ed Tanous9936f862022-09-19 09:13:20 -07001# The below configs are expected to be overriden by machine layer
2SUMMARY = "Phosphor PSU software manager"
3DESCRIPTION = "Providing PSU firmware version and upgrade"
Lei YU5422b0a2019-12-23 15:41:17 +08004HOMEPAGE = "https://github.com/openbmc/phosphor-psu-code-mgmt"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
Lei YU5422b0a2019-12-23 15:41:17 +08007DEPENDS = " \
8 phosphor-logging \
9 phosphor-dbus-interfaces \
10 sdbusplus \
11 openssl \
12 "
Ed Tanous9936f862022-09-19 09:13:20 -070013SRCREV = "97092314b107744e290b3fd6cf0eeef43247400c"
14PV = "1.0+git${SRCPV}"
15PR = "r1"
Lei YU5422b0a2019-12-23 15:41:17 +080016
Ed Tanous9936f862022-09-19 09:13:20 -070017SRC_URI += "git://github.com/openbmc/phosphor-psu-code-mgmt;branch=master;protocol=https"
Lei YU5422b0a2019-12-23 15:41:17 +080018
Ed Tanous9936f862022-09-19 09:13:20 -070019S = "${WORKDIR}/git"
20SYSTEMD_SERVICE:${PN} = "xyz.openbmc_project.Software.Psu.Updater.service"
21SYSTEMD_SERVICE:${PN} += "psu-update@.service"
Lei YU5422b0a2019-12-23 15:41:17 +080022
Ed Tanous9936f862022-09-19 09:13:20 -070023inherit meson
24inherit pkgconfig
25inherit obmc-phosphor-systemd
Lei YU5422b0a2019-12-23 15:41:17 +080026
27EXTRA_OEMESON = " \
28 -Dtests=disabled \
29 ${PSU_VERSION_UTIL} \
30 ${PSU_VERSION_COMPARE_UTIL} \
31 ${PSU_UPDATE_SERVICE} \
32 "
33
Ed Tanous9936f862022-09-19 09:13:20 -070034# The default config of this repo depends on utils from phosphor-power.
35# If your system does not depend on phosphor-power, please use
36# RDEPENDS:${PN}:remove to remove the dependency.
37RDEPENDS:${PN} += "phosphor-power"
38
39## The psutils here comes from phosphor-power repo where
40## * PSU_VERSION_UTIL accepts a PSU inventory path and returns the PSU
41## firmware version string
42## * PSU_VERSION_COMPARE_UTIL accepts several PSU inventory paths and return
43## the newest version string
44PSU_VERSION_UTIL ?= "-DPSU_VERSION_UTIL='/usr/bin/psutils --raw --get-version'"
45PSU_VERSION_COMPARE_UTIL ?= "-DPSU_VERSION_COMPARE_UTIL='/usr/bin/psutils --raw --compare'"
46## The psu-update@.service from repo is an example service that only prints a log and fails
47## Override it in a machine layer to invoke the psu update util
48PSU_UPDATE_SERVICE ?= "-DPSU_UPDATE_SERVICE=psu-update@.service"