blob: ead87870e2f93cbf5c18ab867eb15920ddf90623 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Dependency management tool for Golang"
2HOMEPAGE = "https://github.com/golang/dep"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=1bad315647751fab0007812f70d42c0d"
5
6GO_IMPORT = "github.com/golang/dep"
7SRC_URI = "git://${GO_IMPORT} \
8 file://0001-Add-support-for-mips-mips64.patch;patchdir=src/github.com/golang/dep \
9 "
10
Brad Bishop79641f22019-09-10 07:20:22 -040011SRCREV = "1f7c19e5f52f49ffb9f956f64c010be14683468b"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080012
13inherit go
14
15GO_INSTALL = "${GO_IMPORT}/cmd/dep"
16
17RDEPENDS_${PN}-dev += "bash"
18
19BBCLASSEXTEND = "native nativesdk"
20
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080021# For compiling ptest on mips and mips64, the current go-dep version fails with the go 1.11 toolchain.
22# error message: vet config not found
23PTEST_ENABLED_mips = "0"
24PTEST_ENABLED_mips64 = "0"