Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Dependency management tool for Golang" |
| 2 | HOMEPAGE = "https://github.com/golang/dep" |
| 3 | LICENSE = "BSD-3-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=1bad315647751fab0007812f70d42c0d" |
| 5 | |
| 6 | GO_IMPORT = "github.com/golang/dep" |
| 7 | SRC_URI = "git://${GO_IMPORT} \ |
| 8 | file://0001-Add-support-for-mips-mips64.patch;patchdir=src/github.com/golang/dep \ |
| 9 | " |
| 10 | |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 11 | SRCREV = "1f7c19e5f52f49ffb9f956f64c010be14683468b" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 12 | |
| 13 | inherit go |
| 14 | |
| 15 | GO_INSTALL = "${GO_IMPORT}/cmd/dep" |
| 16 | |
| 17 | RDEPENDS_${PN}-dev += "bash" |
| 18 | |
| 19 | BBCLASSEXTEND = "native nativesdk" |
| 20 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 21 | # For compiling ptest on mips and mips64, the current go-dep version fails with the go 1.11 toolchain. |
| 22 | # error message: vet config not found |
| 23 | PTEST_ENABLED_mips = "0" |
| 24 | PTEST_ENABLED_mips64 = "0" |