blob: adba8ab2f9acc2c66eda8bd6c6eab28791630d70 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "GNOME editor"
2SECTION = "x11/gnome"
Andrew Geissler9aee5002022-03-30 16:27:02 +00003LICENSE = "GPL-2.0-or-later"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00004LIC_FILES_CHKSUM = "file://COPYING;md5=75859989545e37968a99b631ef42722e"
5
6GNOMEBASEBUILDCLASS = "meson"
7
8DEPENDS = " \
9 gdk-pixbuf-native \
10 gtk+3 \
11 gsettings-desktop-schemas \
12 libpeas \
13 libsoup-2.4 \
14 gspell \
15 gtksourceview4 \
16 tepl \
17"
18
19inherit gnomebase gsettings itstool gnome-help gobject-introspection gtk-doc vala gettext features_check mime-xdg python3targetconfig
20
21def gnome_verdir(v):
22 return oe.utils.trim_version(v, 1)
23
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000024SRC_URI[archive.sha256sum] = "7a9b18b158808d1892989165f3706c4f1a282979079ab7458a79d3c24ad4deb5"
25
26# gobject-introspection is mandatory and cannot be configured
Andrew Geissler9aee5002022-03-30 16:27:02 +000027# x11 is needed for tepl and gtksourceview4
28REQUIRED_DISTRO_FEATURES = "gobject-introspection-data x11"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000029GIR_MESON_OPTION = ""
30
31GTKDOC_MESON_OPTION = "gtk_doc"
32
33PACKAGES += "${PN}-python"
34
35FILES:${PN} += " \
36 ${datadir}/dbus-1 \
37 ${datadir}/metainfo \
38"
39
40FILES:${PN}-python += " \
41 ${PYTHON_SITEPACKAGES_DIR} \
42"
43
44RDEPENDS:${PN} += "gsettings-desktop-schemas"
45RRECOMMENDS:${PN} += "source-code-pro-fonts"