blob: e929534c3fc5b4c43e8f319597cdc71d39b3c056 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Dispatcher service for systemd-networkd connection status changes"
2DESCRIPTION = "This daemon is similar to NetworkManager-dispatcher, but is much \
3more limited in the types of events it supports due to the limited nature of \
4systemd-networkd(8)."
5AUTHOR = "Clayton Craft and others"
6
Andrew Geissler9aee5002022-03-30 16:27:02 +00007LICENSE = "GPL-3.0-only"
Brad Bishopc342db32019-05-15 21:57:59 -04008LIC_FILES_CHKSUM = "file://LICENSE;md5=84dcc94da3adb52b53ae4fa38fe49e5d"
9
Brad Bishop8410d612019-11-25 09:40:59 -050010inherit features_check systemd
Brad Bishop00ab2372019-10-14 11:06:18 -040011
Patrick Williams213cb262021-08-07 19:21:33 -050012RDEPENDS:${PN} = "python3-pygobject python3-dbus"
Brad Bishop00ab2372019-10-14 11:06:18 -040013REQUIRED_DISTRO_FEATURES = "systemd"
Brad Bishopc342db32019-05-15 21:57:59 -040014
Andrew Geissler4b7c1152020-11-30 19:55:29 -060015SRCREV = "30e278e50749a60a930ceaa0971207c6436b8a0c"
16SRC_URI = "git://gitlab.com/craftyguy/networkd-dispatcher;protocol=https;nobranch=1"
17
18S = "${WORKDIR}/git"
Brad Bishopc342db32019-05-15 21:57:59 -040019
Brad Bishop00ab2372019-10-14 11:06:18 -040020SYSTEMD_PACKAGES = "${PN}"
Patrick Williams213cb262021-08-07 19:21:33 -050021SYSTEMD_SERVICE:${PN} = "networkd-dispatcher.service"
Brad Bishop00ab2372019-10-14 11:06:18 -040022SYSTEMD_AUTO_ENABLE = "disable"
23
Brad Bishopc342db32019-05-15 21:57:59 -040024# Nothing to build, just a python script to install
25do_configure[noexec] = "1"
26do_compile[noexec] = "1"
27
28do_install() {
Brad Bishop665fd022019-08-26 01:32:28 -040029 install -D -m 0755 ${S}/networkd-dispatcher ${D}${bindir}/networkd-dispatcher
Brad Bishopc342db32019-05-15 21:57:59 -040030 install -D -m 0644 ${S}/networkd-dispatcher.service ${D}/${systemd_system_unitdir}/networkd-dispatcher.service
31 install -D -m 0644 ${S}/networkd-dispatcher.conf ${D}/${sysconfdir}/conf.d/networkd-dispatcher.conf
32}