blob: 4f8d4f6c6e3a593e619f7b70fd166884a17f8e36 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "IPv4 link-local address allocator"
2DESCRIPTION = "Zeroconf is a program that is used to claim IPv4 \
3link-local addresses. IPv4 link-local addresses are useful when setting \
4up ad-hoc networking between devices without the involvement of a either \
5a DHCP server or network administrator. \
6These addresses are allocated from the 169.254.0.0/16 address range and \
7are normally attached to each Ethernet device in your computer. \
8Addresses are assigned randomly by each host and, in case of collision, \
9both hosts (are supposed to) renumber."
10AUTHOR = "Anand Kumria <wildfire@progsoc.uts.edu.au>"
11HOMEPAGE = "http://www.progsoc.org/~wildfire/zeroconf/"
Andrew Geissler9aee5002022-03-30 16:27:02 +000012LICENSE = "GPL-2.0-or-later"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050013LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4 \
14 file://zeroconf.c;beginline=1;endline=13;md5=a5bada96e1e34b08eb7446b28e2630b2"
15SECTION = "net"
16
17PR = "r1"
18
19SRC_URI = "http://www.progsoc.org/~wildfire/zeroconf/download/${BPN}-${PV}.tar.gz \
20 file://compilefix.patch \
Patrick Williamsddad1a12017-02-23 20:36:32 -060021 file://makefile-add-ldflags.patch \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050022 file://zeroconf-default \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050023 file://debian-zeroconf \
24 file://0001-zeroconf-Rename-arp_op-to-avoid-namespace-conflicts-.patch \
25 "
Patrick Williamsb48b7b42016-08-17 15:04:38 -050026
27SRC_URI[md5sum] = "bdafb16b008ebb5633e4e581f77821d2"
28SRC_URI[sha256sum] = "a8c74df127753e2310fa1e072f3c9ca44a404bb0bbce9cfec7a84c6dff8bec7b"
29
30do_install () {
31 install -d ${D}${sbindir}
32 install -d ${D}${sysconfdir}/network/if-up.d
33 install -d ${D}${sysconfdir}/default
34 install -c -m 755 ${S}/zeroconf ${D}${sbindir}/zeroconf
35 install -c -m 755 ${WORKDIR}/debian-zeroconf ${D}${sysconfdir}/network/if-up.d/zeroconf
36 install -c ${WORKDIR}/zeroconf-default ${D}${sysconfdir}/default/zeroconf
37}