blob: 898b69682d30d9bf38c271a9535e90b11fc03f33 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Administration tool for arp packet filtering"
2SECTION = "net"
Andrew Geissler9aee5002022-03-30 16:27:02 +00003LICENSE = "GPL-2.0-only"
Andrew Geissler97771a32021-03-05 15:23:11 -06004LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6"
Andrew Geissler82c905d2020-04-13 13:39:40 -05005SRCREV = "efae8949e31f8b2eb6290f377a28384cecaf105a"
6PV = "0.0.5+git${SRCPV}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05007
8SRC_URI = " \
Andrew Geissler595f6302022-01-24 19:11:47 +00009 git://git.netfilter.org/arptables;branch=master \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050010 file://0001-Use-ARPCFLAGS-for-package-specific-compiler-flags.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050011 file://arptables-arpt-get-target-fix.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050012 file://arptables.service \
13"
14SRC_URI[arptables.md5sum] = "1d4ab05761f063b0751645d8f2b8f8e5"
15SRC_URI[arptables.sha256sum] = "e529fd465c67d69ad335299a043516e6b38cdcd337a5ed21718413e96073f928"
16
17S = "${WORKDIR}/git"
Patrick Williams213cb262021-08-07 19:21:33 -050018SYSTEMD_SERVICE:${PN} = "arptables.service"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050019
20inherit systemd
21
22EXTRA_OEMAKE = "'BINDIR=${sbindir}' 'MANDIR=${mandir}'"
23
Brad Bishopd7bf8c12018-02-25 22:55:05 -050024do_install() {
25 oe_runmake install DESTDIR=${D}
Brad Bishop6e60e8b2018-02-01 10:27:11 -050026 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
27 install -d ${D}${systemd_unitdir}/system
28 install -m 644 ${WORKDIR}/arptables.service ${D}${systemd_unitdir}/system
29 fi
30}
31
Patrick Williams213cb262021-08-07 19:21:33 -050032RDEPENDS:${PN} += "perl"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050033
34# the install target is not multi-job safe, but it doesn't do much
35# so we just install serially
36#
37PARALLEL_MAKEINST = "-j1"