blob: 01bde4a68df47239cd5fcecd68e731ab4a9d54f1 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Linux Virtual Server administration Utility"
2HOMEPAGE = "http://www.linux-vs.org/software/index.html"
3DESCRIPTION = "Ipvsadm is used to set up, maintain or inspect the virtual server \
4table in the Linux kernel. The Linux Virtual Server can be used to \
5build scalable network services based on a cluster of two or more nodes. \
6The active node of the cluster redirects service requests to a \
7collection of server hosts that will actually perform the services. \
8Supported features include two protocols (TCP and UDP), three packet-forwarding \
9methods (NAT, tunneling, and direct routing), and eight load balancing algorithms \
10(round robin, weighted round robin, least-connec-tion, weighted least-connection, \
11locality-based least-connection, locality-based least-connection with replication, \
12destination-hashing, and source-hashing)."
13SECTION = "net"
Andrew Geissler9aee5002022-03-30 16:27:02 +000014LICENSE = "GPL-2.0-only"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015LIC_FILES_CHKSUM = "file://README;beginline=40;endline=56;md5=b4e40069f15598d0e3fe2aa177e5ec77"
16
17DEPENDS += "libnl popt"
18
Brad Bishop26bdd442019-08-16 17:08:17 -040019SRC_URI = "https://mirrors.edge.kernel.org/pub/linux/utils/kernel/ipvsadm/${BP}.tar.xz \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080020 file://0001-Modify-the-Makefile-for-cross-compile.patch \
21 file://0003-ipvsadm-remove-dependency-on-bash.patch \
22 file://makefile-add-ldflags.patch \
23"
24
Brad Bishope42b3e32020-01-15 22:08:42 -050025SRC_URI[md5sum] = "f6d1707c5baf684b58fd33682d67871f"
26SRC_URI[sha256sum] = "1a0a5e25b5a1226435d2fb76341656f83a710183aebb0d204db39c0ec3bedfdb"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080027
28UPSTREAM_CHECK_URI = "${KERNELORG_MIRROR}/linux/utils/kernel/ipvsadm"
29
30do_compile() {
31 oe_runmake \
32 CC="${CC} -I${STAGING_INCDIR} -I${STAGING_INCDIR}/libnl3 -L${STAGING_LIBDIR}" \
33 all
34}
35
36do_install() {
Brad Bishop6a62e0e2019-10-21 08:11:42 -040037 sed -i -e "s;SBIN\t\t= \$(BUILD_ROOT)/sbin;SBIN\t\t= \$(BUILD_ROOT)$base_sbindir;" \
38 -e "s;INIT\t\t= \$(BUILD_ROOT)/etc/rc.d/init.d;INIT\t\t= \$(BUILD_ROOT)${sysconfdir}/init.d;" \
39 ${S}/Makefile
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080040 oe_runmake 'BUILD_ROOT=${D}' install
41}
42
43inherit pkgconfig