blob: 17bbb9b6ce0686b63b70c536a7d294a06fee1917 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Tests to compare standard functions of different libc implementations"
2DESCRIPTION = "libc-bench is a set of time- and memory-efficiency tests to compare \
3implementations of various C/POSIX standard library functions."
4HOMEPAGE = "http://www.etalabs.net/libc-bench.html"
5SECTION = "console/utils"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=9a825c63897c53f487ef900598c31527"
8
9SRCREV = "b6b2ce5f9f87a09b14499cb00c600c601f022634"
10PV = "20110206+git${SRCPV}"
11
Andrew Geissler595f6302022-01-24 19:11:47 +000012SRC_URI = "git://git.musl-libc.org/libc-bench;branch=master \
Andrew Geissler69721092021-07-23 12:57:00 -040013 file://0001-build-Do-not-override-ldflags-from-environment.patch \
Brad Bishop19323692019-04-05 15:28:33 -040014 "
15
16S = "${WORKDIR}/git"
17
18do_install () {
19 install -d ${D}${bindir}
20 install -m 0755 ${B}/libc-bench ${D}${bindir}
21}
22