blob: 9e54968633a1a735c6077e601a818eb69dcdb49f [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "SMS Gateway software"
2DESCRIPTION = "The SMS Server Tools 3 is a SMS Gateway software which can send and receive short messages through GSM modems and mobile phones."
3SECTION = "console/network"
Andrew Geissler9aee5002022-03-30 16:27:02 +00004LICENSE = "GPL-2.0-only"
Brad Bishop316dfdd2018-06-25 12:45:53 -04005LIC_FILES_CHKSUM = "file://LICENSE;md5=4d21efa1bb2a186360dde4035f860682"
6HOMEPAGE = "http://smstools3.kekekasvi.com"
7
8SRC_URI = "http://smstools3.kekekasvi.com/packages/${BP}.tar.gz \
9 file://sms_binpath.patch \
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050010 file://scripts_no_bash.patch \
11 file://0001-Make-extern-declarations-to-avoid-duplicate-var-defi.patch \
12 "
Brad Bishop316dfdd2018-06-25 12:45:53 -040013
14SRC_URI[md5sum] = "6a9f038fb38a49cc3a4f8f14a88fb8af"
15SRC_URI[sha256sum] = "a26ba4c02b16f6cf13177bffca6c9230dc5fefaeba8e3030cd4e4905f6a92084"
16
17
18S = "${WORKDIR}/${BPN}"
19
20EXTRA_OEMAKE += "LFLAGS='${LDFLAGS}'"
21
22INITSCRIPT_NAME = "sms3"
23INITSCRIPT_PARAMS = "defaults"
24
25inherit update-rc.d
26
27do_install () {
28
29 install -d ${D}${bindir}
30 install -m 755 ${S}/src/smsd "${D}${bindir}/smsd"
31
32 install -m 755 ${S}/scripts/sendsms "${D}${bindir}/sendsms"
33 install -m 755 ${S}/scripts/sms2html "${D}${bindir}/sms2html"
34 install -m 755 ${S}/scripts/sms2unicode "${D}${bindir}/sms2unicode"
35 install -m 755 ${S}/scripts/unicode2sms "${D}${bindir}/unicode2sms"
36
37 install -d ${D}${sysconfdir}
38 install -m 644 ${S}/examples/smsd.conf.easy "${D}${sysconfdir}/smsd.conf"
39
40 install -d "${D}${localstatedir}/spool"
41 install -d "${D}${localstatedir}/spool/sms"
42 install -d "${D}${localstatedir}/spool/sms/incoming"
43 install -d "${D}${localstatedir}/spool/sms/outgoing"
44 install -d "${D}${localstatedir}/spool/sms/checked"
45
46 install -d ${D}${sysconfdir}/init.d
47 install -m 755 ${S}/scripts/sms3 "${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}"
48
49}