blob: 15f6b6fb9ae957eb5e7ce95c05e8bec105851db3 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Python interface to MySQL"
2HOMEPAGE = "https://github.com/farcepest/MySQLdb1"
3SECTION = "devel/python"
Andrew Geissler9aee5002022-03-30 16:27:02 +00004LICENSE = "GPL-2.0-only"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05005LIC_FILES_CHKSUM = "file://GPL-2.0;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6
7DEPENDS = "mysql5"
8
9SRCNAME = "MySQL-python"
10
Brad Bishop19323692019-04-05 15:28:33 -040011SRC_URI = "https://pypi.python.org/packages/source/M/${SRCNAME}/${SRCNAME}-${PV}.zip \
12 file://0001-_mysql.c-fix-compilation-with-MariaDB-with-10.3.13.patch \
13"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050014SRC_URI[md5sum] = "654f75b302db6ed8dc5a898c625e030c"
15SRC_URI[sha256sum] = "811040b647e5d5686f84db415efd697e6250008b112b6909ba77ac059e140c74"
16
17S = "${WORKDIR}/${SRCNAME}-${PV}"
18
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000019SKIP_RECIPE[mysql-python] ?= "${@bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', '', 'python2 is out of support for long time, read https://www.python.org/doc/sunset-python-2/ https://python3statement.org/ and if you really have to temporarily use this, then set I_SWEAR_TO_MIGRATE_TO_PYTHON3 to "yes"', d)}"
Andrew Geissler32b11992021-03-31 13:37:05 -050020
Andrew Geissler82c905d2020-04-13 13:39:40 -050021inherit ${@bb.utils.contains("BBFILE_COLLECTIONS", "meta-python2", "setuptools", "", d)}
22
23python() {
24 if 'meta-python2' not in d.getVar('BBFILE_COLLECTIONS').split():
25 raise bb.parse.SkipRecipe('Requires meta-python2 to be present.')
26}