blob: 8b3608a2482d856f04ef73b6a7d6f81e88e0e43e [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001DESCRIPTION = "A small tool to provide detailed information on the hardware \
2configuration of the machine. It can report exact memory configuration, \
3firmware version, mainboard configuration, CPU version and speed, cache \
4configuration, bus speed, etc. on DMI-capable or EFI systems."
5SUMMARY = "Hardware lister"
6HOMEPAGE = "http://ezix.org/project/wiki/HardwareLiSter"
7SECTION = "console/tools"
8
Andrew Geissler9aee5002022-03-30 16:27:02 +00009LICENSE = "GPL-2.0-or-later"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080010LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
11
12COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
13
14SRC_URI = " \
15 http://ezix.org/software/files/lshw-B.${PV}.tar.gz \
Andrew Geisslerd688a012020-09-18 13:36:00 -050016 file://0001-Fix-musl-build.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080017"
Andrew Geisslerd688a012020-09-18 13:36:00 -050018SRC_URI[md5sum] = "8c70d46e906688309095c73ecb9396e3"
19SRC_URI[sha256sum] = "9bb347ac87142339a366a1759ac845e3dbb337ec000aa1b99b50ac6758a80f80"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080020
21S = "${WORKDIR}/lshw-B.${PV}"
22
23do_compile() {
24 # build core only - don't ship gui
25 oe_runmake -C src core
26}
27
28do_install() {
29 oe_runmake install DESTDIR=${D}
30}
Brad Bishop19323692019-04-05 15:28:33 -040031
32BBCLASSEXTEND = "native"