blob: 0eb214626505f8c9971b978f857c66a2f62cd35a [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Security-focused ELF files checking tool"
2DESCRIPTION = "This is a small set of various PaX aware and related \
3utilities for ELF binaries. It can check ELF binary files and running \
4processes for issues that might be relevant when using ELF binaries \
5along with PaX, such as non-PIC code or executable stack and heap."
6HOMEPAGE = "http://www.gentoo.org/proj/en/hardened/pax-utils.xml"
Andrew Geissler9aee5002022-03-30 16:27:02 +00007LICENSE = "GPL-2.0-or-later"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05008LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
9
Brad Bishopd7bf8c12018-02-25 22:55:05 -050010SRC_URI = "https://dev.gentoo.org/~vapier/dist/pax-utils-${PV}.tar.xz"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050011SRC_URI[md5sum] = "a580468318f0ff42edf4a8cd314cc942"
12SRC_URI[sha256sum] = "7f4a7f8db6b4743adde7582fa48992ad01776796fcde030683732f56221337d9"
13
Patrick Williams213cb262021-08-07 19:21:33 -050014RDEPENDS:${PN} += "bash"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050015
16export GNULIB_OVERRIDES_WINT_T = "0"
17
Patrick Williams213cb262021-08-07 19:21:33 -050018do_configure:prepend() {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050019 touch ${S}/NEWS ${S}/AUTHORS ${S}/ChangeLog ${S}/README
20}
21
22do_install() {
23 oe_runmake PREFIX=${D}${prefix} DESTDIR=${D} install
24}
25
26BBCLASSEXTEND = "native"
27
28inherit autotools pkgconfig
29
30PACKAGECONFIG ??= ""
31
32PACKAGECONFIG[libcap] = "--with-caps, --without-caps, libcap"
33PACKAGECONFIG[libseccomp] = "--with-seccomp, --without-seccomp, libseccomp"
34PACKAGECONFIG[pyelftools] = "--with-python, --without-python,, pyelftools"
35
36EXTRA_OECONF += "--enable-largefile"