blob: 94f98fe40f1b650c5e16e9a5e86bddccfc743416 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "The Perl Database Interface"
2DESCRIPTION = "DBI is a database access Application Programming Interface \
3(API) for the Perl Language. The DBI API Specification defines a set \
4of functions, variables and conventions that provide a consistent \
5database interface independent of the actual database being used. \
6"
7HOMEPAGE = "http://search.cpan.org/dist/DBI/"
8SECTION = "libs"
Andrew Geissler9aee5002022-03-30 16:27:02 +00009LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
Andrew Geissler82c905d2020-04-13 13:39:40 -050010LIC_FILES_CHKSUM = "file://LICENSE;md5=10982c7148e0a012c0fd80534522f5c5"
11
Patrick Williams0ca19cc2021-08-16 14:03:13 -050012SRC_URI = "http://search.cpan.org/CPAN/authors/id/T/TI/TIMB/DBI-${PV}.tar.gz \
13 file://CVE-2014-10402.patch \
14 "
Andrew Geissler82c905d2020-04-13 13:39:40 -050015SRC_URI[md5sum] = "352f80b1e23769c116082a90905d7398"
16SRC_URI[sha256sum] = "8a2b993db560a2c373c174ee976a51027dd780ec766ae17620c20393d2e836fa"
17
18S = "${WORKDIR}/DBI-${PV}"
19
20inherit cpan ptest-perl
21
Patrick Williams213cb262021-08-07 19:21:33 -050022do_install:prepend() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050023 # test requires "-T" (taint) command line option
24 rm -rf ${B}/t/pod-coverage.t
25 rm -rf ${B}/t/13taint.t
26 # source of test failure not obvious
27 rm -rf ${B}/t/85gofer.t
28 # unclear why there are several duplicates of tests in tarball
29 rm -rf ${B}/t/z*.t
30}
31
Patrick Williams213cb262021-08-07 19:21:33 -050032RDEPENDS:${PN}:class-target = " \
Andrew Geissler82c905d2020-04-13 13:39:40 -050033 perl \
34 perl-module-carp \
35 perl-module-exporter \
36 perl-module-exporter-heavy \
37 perl-module-dynaloader \
38 perl-module-io-dir \
39 perl-module-scalar-util \
40 perl-module-universal \
41"
42
Patrick Williams213cb262021-08-07 19:21:33 -050043RDEPENDS:${PN}-ptest = " \
Andrew Geissler82c905d2020-04-13 13:39:40 -050044 ${PN} \
45 perl-module-b \
46 perl-module-benchmark \
47 perl-module-cwd \
48 perl-module-data-dumper \
49 perl-module-encode \
50 perl-module-encode-byte \
51 perl-module-encode-encoding \
52 perl-module-file-copy \
53 perl-module-file-path \
54 perl-module-lib \
55 perl-module-perlio \
56 perl-module-perlio-scalar \
57 perl-module-perlio-via \
58 perl-module-sdbm-file \
59 perl-module-storable \
60 perl-module-test-more \
61 perl-module-utf8 \
62 "
63
64BBCLASSEXTEND = "native"