blob: 4f8ea64a26b3170dc3f00abe6528522083b0e137 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Tools for taking the MD5 sum of ISO images"
2DESCRIPTION = "Tools for taking the MD5 sum of ISO images"
3
4DEPENDS = "popt python3 openssl curl popt-native"
Patrick Williams213cb262021-08-07 19:21:33 -05005RDEPENDS:${BPN} = "openssl curl"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08006
Andrew Geissler9aee5002022-03-30 16:27:02 +00007LICENSE = "GPL-2.0-only"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08008LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
9
Andrew Geissler595f6302022-01-24 19:11:47 +000010SRC_URI = "git://github.com/rhinstaller/isomd5sum.git;branch=master;protocol=https \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011 file://0001-tweak-install-prefix.patch \
12 file://0002-fix-parallel-error.patch \
13"
14
15S = "${WORKDIR}/git"
16inherit python3native
17
18EXTRA_OEMAKE += " \
19 DESTDIR='${D}' \
20 PYTHONINCLUDE='-I${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}' \
21 PYTHONSITEPACKAGES='${PYTHON_SITEPACKAGES_DIR}' \
22"
23
24do_install () {
25 oe_runmake install
26}
27
Brad Bishop26bdd442019-08-16 17:08:17 -040028PACKAGES += "${PYTHON_PN}-${BPN}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080029
Patrick Williams213cb262021-08-07 19:21:33 -050030RPROVIDES:${BPN}-dbg += "${PYTHON_PN}-${BPN}-dbg"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080031
Patrick Williams213cb262021-08-07 19:21:33 -050032FILES:${PYTHON_PN}-${BPN} = "${PYTHON_SITEPACKAGES_DIR}/pyisomd5sum.so"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080033
34SRCREV = "7860901f726f5d92689cb67243cc7f981f21f74b"
35
36BBCLASSEXTEND = "native"