blob: 3e6df5689a6d7f99a654c7b1b74bfb1f2dd290a5 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001DESCRIPTION = "libblockdev is a C library supporting GObject introspection for manipulation of \
2block devices. It has a plugin-based architecture where each technology (like \
3LVM, Btrfs, MD RAID, Swap,...) is implemented in a separate plugin, possibly \
4with multiple implementations (e.g. using LVM CLI or the new LVM DBus API)."
5HOMEPAGE = "http://rhinstaller.github.io/libblockdev/"
Andrew Geissler9aee5002022-03-30 16:27:02 +00006LICENSE = "LGPL-2.0-or-later"
Brad Bishop19323692019-04-05 15:28:33 -04007SECTION = "devel/lib"
8
9LIC_FILES_CHKSUM = "file://LICENSE;md5=c07cb499d259452f324bb90c3067d85c"
10
Andrew Geissler5199d832021-09-24 16:47:35 -050011inherit autotools gobject-introspection pkgconfig
Brad Bishop19323692019-04-05 15:28:33 -040012
Andrew Geissler595f6302022-01-24 19:11:47 +000013SRC_URI = "git://github.com/storaged-project/libblockdev;branch=2.x-branch;protocol=https \
14 file://0001-lvm-Do-not-include-duplicate-entries-in-bd_lvm_lvs-o.patch \
15"
Patrick Williams213cb262021-08-07 19:21:33 -050016SRCREV = "47ff12242c89e36a33259d18b7068b26c3bb1c64"
Brad Bishop19323692019-04-05 15:28:33 -040017S = "${WORKDIR}/git"
18
Patrick Williams213cb262021-08-07 19:21:33 -050019FILES:${PN} += "${libdir}/python2.7/dist-packages ${libdir}/python3.*/site-packages"
Brad Bishop19323692019-04-05 15:28:33 -040020
21PACKAGECONFIG ??= "python3 lvm dm kmod parted fs escrow btrfs crypto mdraid kbd mpath nvdimm"
22PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3"
Brad Bishop0f291cc2019-09-01 15:16:57 -040023PACKAGECONFIG[python2] = "--with-python2, --without-python2,,python"
Brad Bishop19323692019-04-05 15:28:33 -040024PACKAGECONFIG[lvm] = "--with-lvm, --without-lvm, multipath-tools, lvm2"
25PACKAGECONFIG[lvm-dbus] = "--with-lvm_dbus, --without-lvm_dbus, multipath-tools, lvm2"
26PACKAGECONFIG[dm] = "--with-dm, --without-dm, multipath-tools, lvm2"
27PACKAGECONFIG[dmraid] = "--with-dmraid, --without-dmraid"
28PACKAGECONFIG[kmod] = "--with-kbd, --without-kbd, kmod"
29PACKAGECONFIG[parted] = "--with-part, --without-part, parted"
30PACKAGECONFIG[fs] = "--with-fs, --without-fs, util-linux"
31PACKAGECONFIG[doc] = "--with-gtk-doc, --without-gtk-doc, gtk-doc-native"
32PACKAGECONFIG[nvdimm] = "--with-nvdimm, --without-nvdimm, ndctl util-linux"
33PACKAGECONFIG[vdo] = "--with-vdo, --without-vdo"
34PACKAGECONFIG[escrow] = "--with-escrow, --without-escrow, nss volume-key"
35PACKAGECONFIG[btrfs] = "--with-btrfs,--without-btrfs,libbytesize btrfs-tools"
36PACKAGECONFIG[crypto] = "--with-crypto,--without-crypto,cryptsetup nss volume-key"
37PACKAGECONFIG[mdraid] = "--with-mdraid,--without-mdraid,libbytesize"
38PACKAGECONFIG[kbd] = "--with-kbd,--without-kbd,libbytesize"
39PACKAGECONFIG[mpath] = "--with-mpath,--without-mpath, multipath-tools, lvm2"
40
41export GIR_EXTRA_LIBS_PATH="${B}/src/utils/.libs"