blob: db4f507b7c32c4f33a2c2f319ff543e8265481ff [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "A library to handle Apple Property List format whereas it's binary or XML"
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -05002HOMEPAGE = "https://github.com/libimobiledevice/libplist"
Andrew Geissler9aee5002022-03-30 16:27:02 +00003LICENSE = "GPL-2.0-only & LGPL-2.1-only"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08004LIC_FILES_CHKSUM = "file://COPYING;md5=ebb5c50ab7cab4baeffba14977030c07 \
5 file://COPYING.LESSER;md5=6ab17b41640564434dda85c06b7124f7"
6
Andrew Geissler82c905d2020-04-13 13:39:40 -05007DEPENDS = "libxml2 glib-2.0 swig python3"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08008
Andrew Geissler4b7c1152020-11-30 19:55:29 -06009inherit autotools pkgconfig python3native python3targetconfig
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080010
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050011SRCREV = "c5a30e9267068436a75b5d00fcbf95cb9c1f4dcd"
Andrew Geissler595f6302022-01-24 19:11:47 +000012SRC_URI = "git://github.com/libimobiledevice/libplist;protocol=https;branch=master"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013
14S = "${WORKDIR}/git"
15
Patrick Williams213cb262021-08-07 19:21:33 -050016do_install:append () {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080017 if [ -e ${D}${libdir}/python*/site-packages/plist/_plist.so ]; then
18 chrpath -d ${D}${libdir}/python*/site-packages/plist/_plist.so
19 fi
20}
21
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050022PACKAGES =+ "${PN}-utils \
23 ${PN}++ \
24 ${PN}-python"
25
Patrick Williams213cb262021-08-07 19:21:33 -050026FILES:${PN} = "${libdir}/libplist-2.0${SOLIBS}"
27FILES:${PN}++ = "${libdir}/libplist++-2.0${SOLIBS}"
28FILES:${PN}-utils = "${bindir}/*"
29FILES:${PN}-python = "${libdir}/python*/site-packages/*"