blob: 8dca2940b5db929392fc9f3d6e5222ba86dd1a0c [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Hardware performance monitoring counters"
Andrew Geissler595f6302022-01-24 19:11:47 +00002HOMEPAGE = "https://team.inria.fr/pacap/software/tiptop/"
Andrew Geissler9aee5002022-03-30 16:27:02 +00003LICENSE = "GPL-2.0-only"
Brad Bishop316dfdd2018-06-25 12:45:53 -04004LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08005DEPENDS = "ncurses libxml2 bison-native flex-native"
Brad Bishop316dfdd2018-06-25 12:45:53 -04006
Andrew Geissler595f6302022-01-24 19:11:47 +00007SRC_URI = "http://files.inria.fr/pacap/${BPN}/${BP}.tar.gz \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08008 file://0001-Fix-parallel-build-problems-by-Adrian-Bunk.patch \
9 file://0002-fix-reproducibility-of-build-process.patch \
10 file://0001-Fix-build-when-S-B.patch \
Andrew Geissler595f6302022-01-24 19:11:47 +000011 file://0001-Fix-a-lot-of-Werror-format-security-errors-with-mvwp.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080012 "
Brad Bishop316dfdd2018-06-25 12:45:53 -040013SRC_URI[sha256sum] = "51c4449c95bba34f16b429729c2f58431490665d8093efaa8643b2e1d1084182"
14
Andrew Geissler595f6302022-01-24 19:11:47 +000015UPSTREAM_CHECK_URI = "https://team.inria.fr/pacap/software/tiptop/"
16
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080017inherit autotools
18
Brad Bishop316dfdd2018-06-25 12:45:53 -040019EXTRA_OECONF = "CFLAGS="$CFLAGS -I${STAGING_INCDIR}/libxml2""
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080020COMPATIBLE_HOST = "(i.86|x86_64|arm|powerpc|aarch64).*-linux"
Brad Bishop316dfdd2018-06-25 12:45:53 -040021
Patrick Williams213cb262021-08-07 19:21:33 -050022do_configure:prepend () {
Brad Bishop316dfdd2018-06-25 12:45:53 -040023 # Two bugs in configure.ac when cross-compiling.
24 # 1. The path of libxml2. Specify it in EXTRA_OECONF.
25 # 2. hw's value on other platforms. Replace it if the target is
26 # not i*86/x86_64.
27 if ( echo "${TARGET_ARCH}" | grep -q -e 'i.86' -e 'x86_64' ); then
28 sed -i 's= -I/usr/include/libxml2==' ${S}/configure.ac
29 else
30 sed -i 's/hw=`uname -m`/hw="unknown"/' ${S}/configure.ac
31 sed -i 's= -I/usr/include/libxml2==' ${S}/configure.ac
32 fi
33}