blob: 032e85f522baa5314dcd9859dd8c931459ed33c9 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001# SPDX-FileCopyrightText: Huawei Inc.
Andrew Geissler595f6302022-01-24 19:11:47 +00002#
Andrew Geisslereff27472021-10-29 15:35:00 -05003# SPDX-License-Identifier: MIT
4
Andrew Geisslereff27472021-10-29 15:35:00 -05005HOMEPAGE = "https://docs.lvgl.io"
6SUMMARY = "PNG decoder for LVGL"
7DESCRIPTION = "Allow the use of PNG images in LVGL. This implementation uses lodepng"
Andrew Geissler595f6302022-01-24 19:11:47 +00008LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=d6fc0df890c5270ef045981b516bb8f2"
10
11SRC_URI = "git://github.com/lvgl/lv_lib_png;destsuffix=${S};protocol=https;nobranch=1"
12SRCREV = "bf1531afe07c9f861107559e29ab8a2d83e4715a"
Andrew Geisslereff27472021-10-29 15:35:00 -050013
14# because of lvgl dependency
15REQUIRED_DISTRO_FEATURES = "wayland"
16
17DEPENDS += "lvgl"
18
Andrew Geissler9aee5002022-03-30 16:27:02 +000019EXTRA_OECMAKE += "-DLIB_INSTALL_DIR=${BASELIB}"
20
Andrew Geisslereff27472021-10-29 15:35:00 -050021inherit cmake
22inherit features_check
23
24TARGET_CFLAGS += "-DLV_CONF_INCLUDE_SIMPLE=1"
25TARGET_CFLAGS += "-I${RECIPE_SYSROOT}/${includedir}/lvgl"
26
27FILES:${PN}-dev = "\
28 ${includedir}/lvgl/lv_lib_png/ \
29 "