blob: c2000b264ba4110cd045501fb9242ce61aa80395 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "An abstraction layer for touchscreen panel events"
2DESCRIPTION = "Tslib is an abstraction layer for touchscreen panel \
3events, as well as a filter stack for the manipulation of those events. \
4Tslib is generally used on embedded devices to provide a common user \
5space interface to touchscreen functionality."
6HOMEPAGE = "http://tslib.org/"
7
8AUTHOR = "Martin Kepplinger <martink@posteo.de>"
9SECTION = "base"
Andrew Geissler9aee5002022-03-30 16:27:02 +000010LICENSE = "LGPL-2.0-or-later & GPL-2.0-or-later"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011LIC_FILES_CHKSUM = "\
12 file://COPYING;md5=fc178bcd425090939a8b634d1d6a9594 \
13 file://tests/COPYING;md5=a23a74b3f4caf9616230789d94217acb \
14"
15
16SRC_URI = "https://github.com/kergoth/tslib/releases/download/${PV}/tslib-${PV}.tar.xz;downloadfilename=tslib-${PV}.tar.xz \
17 file://ts.conf \
18 file://tslib.sh \
Andrew Geisslerd221e032020-07-10 16:13:21 -050019 "
20SRC_URI[sha256sum] = "aaf0aed410a268d7b51385d07fe4d9d64312038e87c447ec8a24c8db0a15617a"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080021
22UPSTREAM_CHECK_URI = "https://github.com/kergoth/tslib/releases"
23
24inherit autotools pkgconfig
25
Andrew Geisslerf103a7f2021-05-07 16:09:40 -050026PACKAGECONFIG ??= "debounce dejitter evthres iir linear median pthres skip lowpass invert variance input touchkit waveshare"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080027PACKAGECONFIG[debounce] = "--enable-debounce,--disable-debounce"
28PACKAGECONFIG[dejitter] = "--enable-dejitter,--disable-dejitter"
Andrew Geisslerf103a7f2021-05-07 16:09:40 -050029PACKAGECONFIG[evthres] = "--enable-evthres,--disable-evthres"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080030PACKAGECONFIG[iir] = "--enable-iir,--disable-iir"
31PACKAGECONFIG[linear] = "--enable-linear,--disable-linear"
32PACKAGECONFIG[median] = "--enable-median,--disable-median"
33PACKAGECONFIG[pthres] = "--enable-pthres,--disable-pthres"
34PACKAGECONFIG[skip] = "--enable-skip,--disable-skip"
35PACKAGECONFIG[lowpass] = "--enable-lowpass,--disable-lowpass"
36PACKAGECONFIG[invert] = "--enable-invert,--disable-invert"
37PACKAGECONFIG[variance] = "--enable-variance,--disable-variance"
38PACKAGECONFIG[input] = "--enable-input,--disable-input"
39PACKAGECONFIG[tatung] = "--enable-tatung,--disable-tatung"
40PACKAGECONFIG[touchkit] = "--enable-touchkit,--disable-touchkit"
41PACKAGECONFIG[waveshare] = "--enable-waveshare,--disable-waveshare"
42PACKAGECONFIG[ucb1x00] = "--enable-ucb1x00,--disable-ucb1x00"
43PACKAGECONFIG[mk712] = "--enable-mk712,--disable-mk712"
44PACKAGECONFIG[h3600] = "--enable-h3600,--disable-h3600"
45PACKAGECONFIG[dmc] = "--enable-dmc,--disable-dmc"
46PACKAGECONFIG[linear-h2200] = "--enable-linear-h2200,--disable-linear-h2200"
47PACKAGECONFIG[corgi] = "--enable-corgi,--disable-corgi"
48PACKAGECONFIG[collie] = "--enable-collie,--disable-collie"
49PACKAGECONFIG[arctic2] = "--enable-arctic2,--disable-arctic2"
50PACKAGECONFIG[dmc_dus3000] = "--enable-dmc_dus3000,--disable-dmc_dus3000"
51PACKAGECONFIG[cy8mrln-palmpre] = "--enable-cy8mrln-palmpre,--disable-cy8mrln-palmpre"
52PACKAGECONFIG[galax] = "--enable-galax,--disable-galax"
Andrew Geisslerf103a7f2021-05-07 16:09:40 -050053PACKAGECONFIG[one-wire-ts-input] = "--enable-one-wire-ts-input,--disable-one-wire-ts-input"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080054PACKAGECONFIG[debug] = "--enable-debug,--disable-debug"
55
Patrick Williams213cb262021-08-07 19:21:33 -050056do_install:prepend() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080057 install -m 0644 ${WORKDIR}/ts.conf ${S}/etc/ts.conf
58}
59
Patrick Williams213cb262021-08-07 19:21:33 -050060do_install:append() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080061 install -d ${D}${sysconfdir}/profile.d/
62 install -m 0755 ${WORKDIR}/tslib.sh ${D}${sysconfdir}/profile.d/
63}
64
Patrick Williams213cb262021-08-07 19:21:33 -050065RPROVIDES:tslib-conf = "libts-0.0-conf"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080066
67PACKAGES =+ "tslib-conf tslib-tests tslib-calibrate tslib-uinput"
Patrick Williams213cb262021-08-07 19:21:33 -050068DEBIAN_NOAUTONAME:tslib-conf = "1"
69DEBIAN_NOAUTONAME:tslib-tests = "1"
70DEBIAN_NOAUTONAME:tslib-calibrate = "1"
71DEBIAN_NOAUTONAME:tslib-uinput = "1"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080072
Patrick Williams213cb262021-08-07 19:21:33 -050073RDEPENDS:${PN} = "tslib-conf"
74RRECOMMENDS:${PN} = "pointercal"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080075
Patrick Williams213cb262021-08-07 19:21:33 -050076FILES:${PN}-dev += "${libdir}/ts/*.la"
77FILES:tslib-conf = "${sysconfdir}/ts.conf ${sysconfdir}/profile.d/tslib.sh ${datadir}/tslib"
78FILES:${PN} = "${libdir}/*.so.* ${libdir}/ts/*.so*"
79FILES:tslib-calibrate += "${bindir}/ts_calibrate"
80FILES:tslib-uinput += "${bindir}/ts_uinput"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080081
Patrick Williams213cb262021-08-07 19:21:33 -050082FILES:tslib-tests = "${bindir}/ts_harvest ${bindir}/ts_print ${bindir}/ts_print_raw ${bindir}/ts_print_mt \
Brad Bishop2f973922019-11-11 07:58:48 -050083 ${bindir}/ts_test ${bindir}/ts_test_mt ${bindir}/ts_verify ${bindir}/ts_finddev ${bindir}/ts_conf"