blob: f386d6ec582d336efe2b71bf8cafa630b882fb31 [file] [log] [blame]
Patrick Williamsddad1a12017-02-23 20:36:32 -06001require ttf.inc
2
3SUMMARY = "Liberation(tm) Fonts"
4DESCRIPTION = "The Liberation(tm) Fonts is a font family originally \
5created by Ascender(c) which aims at metric compatibility with \
6Arial, Times New Roman, Courier New."
7
8HOMEPAGE = "https://fedorahosted.org/liberation-fonts/"
Andrew Geissler9aee5002022-03-30 16:27:02 +00009LICENSE = "GPL-2.0-only"
Patrick Williamsddad1a12017-02-23 20:36:32 -060010LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
11
Brad Bishop7f28bc52017-12-03 23:42:40 -050012SRC_URI = "https://releases.pagure.org/liberation-fonts/liberation-fonts-ttf-${PV}.tar.gz \
Patrick Williamsddad1a12017-02-23 20:36:32 -060013 file://30-0-liberation-sans-narrow.conf \
14"
15
16SRC_URI[md5sum] = "134d8262145fc793c6af494dcace3e71"
17SRC_URI[sha256sum] = "61a7e2b6742a43c73e8762cdfeaf6dfcf9abdd2cfa0b099a9854d69bc4cfee5c"
18
19S = "${WORKDIR}/liberation-fonts-ttf-${PV}"
20
Patrick Williams213cb262021-08-07 19:21:33 -050021do_install:append () {
Patrick Williamsddad1a12017-02-23 20:36:32 -060022 install -d ${D}${datadir}/fonts/TTF/
23 install -d ${D}${sysconfdir}/fonts/conf.d/
24 install -m 0644 LiberationSansNarrow*.ttf ${D}${datadir}/fonts/TTF/
25 install -D -m 0644 ${WORKDIR}/30-0-liberation-sans-narrow.conf ${D}${sysconfdir}/conf.avail/30-${PN}-sans.conf
26 install -D -m 0644 ${S}/License.txt ${D}${datadir}/licenses/${PN}/LICENSE
Andrew Geisslerd688a012020-09-18 13:36:00 -050027 # normal liberation fonts come from ttf-liberation recipe so delete here
28 rm -rf ${D}${datadir}/fonts/truetype
Patrick Williamsddad1a12017-02-23 20:36:32 -060029}
30
31PACKAGES = "${PN}"
32FONT_PACKAGES = "${PN}"
33
Patrick Williams213cb262021-08-07 19:21:33 -050034FILES:${PN} = "${datadir}/fonts ${sysconfdir} ${datadir}/licenses"