blob: 3abb629446e17ff6097466048159773e668ea751 [file] [log] [blame]
Brad Bishop15ae2502019-06-18 21:44:24 -04001SUMMARY = "The Geolocation Service"
2DESCRIPTION = "Geoclue is a D-Bus service that provides location information. \
3The primary goal of the Geoclue project is to make creating location-aware applications \
4as simple as possible, while the secondary goal is to ensure that no application \
5can access location information without explicit permission from user."
Andrew Geissler9aee5002022-03-30 16:27:02 +00006LICENSE = "GPL-2.0-or-later"
Brad Bishop15ae2502019-06-18 21:44:24 -04007SECTION = "console/network"
8
9LIC_FILES_CHKSUM = "file://COPYING;md5=bdfdd4986a0853eb84eeba85f9d0c4d6"
10
11DEPENDS = "glib-2.0 dbus json-glib libsoup-2.4 intltool-native"
12
13inherit meson pkgconfig gtk-doc gobject-introspection vala
14
Andrew Geissler72956ed2021-01-08 16:11:14 -060015SRCREV = "3bb60dd600a8b247fd6049e7e5b1c73c2c5fc0e8"
Andrew Geissler4b7c1152020-11-30 19:55:29 -060016SRC_URI = "git://gitlab.freedesktop.org/geoclue/geoclue.git;protocol=https;nobranch=1"
Brad Bishop15ae2502019-06-18 21:44:24 -040017
Andrew Geissler4b7c1152020-11-30 19:55:29 -060018S = "${WORKDIR}/git"
Brad Bishop15ae2502019-06-18 21:44:24 -040019
20# Without this line, package is declared a library and named libgeoclue*
21AUTO_LIBNAME_PKGS = ""
22
23PACKAGECONFIG ??= "3g modem-gps cdma nmea lib"
24PACKAGECONFIG[3g] = "-D3g-source=true,-D3g-source=false,modemmanager"
25PACKAGECONFIG[modem-gps] = "-Dmodem-gps-source=true,-Dmodem-gps-source=false,modemmanager"
26PACKAGECONFIG[cdma] = "-Dcdma-source=true,-Dcdma-source=false,modemmanager"
Andrew Geissler89770b02020-06-13 10:40:47 -050027PACKAGECONFIG[nmea] = "-Dnmea-source=true,-Dnmea-source=false,avahi,avahi-daemon"
Brad Bishop15ae2502019-06-18 21:44:24 -040028PACKAGECONFIG[lib] = "-Dlibgeoclue=true,-Dlibgeoclue=false,gobject-introspection"
29
30GTKDOC_MESON_OPTION = "gtk-doc"
31
32EXTRA_OEMESON += " \
33 -Ddbus-sys-dir=${sysconfdir}/dbus-1/system.d \
34 -Ddemo-agent=false \
35"
36
Patrick Williams213cb262021-08-07 19:21:33 -050037FILES:${PN} += " \
Brad Bishop15ae2502019-06-18 21:44:24 -040038 ${datadir}/dbus-1/system-services \
39 ${libdir} \
40 ${systemd_unitdir} \
41 ${prefix}/libexec \
42"
43
Patrick Williams213cb262021-08-07 19:21:33 -050044FILES:${PN}-dev += " \
Brad Bishop15ae2502019-06-18 21:44:24 -040045 ${datadir}/dbus-1/interfaces \
46 ${datadir}/gir-1.0 \
47"