blob: 5c05271d176fc98b16fb174d619c3e4725616137 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "A privileged helper for utmp/wtmp updates"
2DESCRIPTION = "\
3This library provides interface for terminal emulators such as \
4screen and xterm to record user sessions to utmp and wtmp files."
5HOMEPAGE = "ftp://ftp.altlinux.org/pub/people/ldv/utempter"
6SECTION = "System Environment/Libraries"
Andrew Geissler9aee5002022-03-30 16:27:02 +00007LICENSE = "GPL-2.0-only & GPL-2.0-or-later & LGPL-2.0-only & MIT"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05008LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
9
10SRCREV = "3ef74fff310f09e2601e241b9f042cd39d591018"
11PV = "1.1.6-alt2+git${SRCPV}"
12
Andrew Geissler595f6302022-01-24 19:11:47 +000013SRC_URI = "git://git.altlinux.org/people/ldv/packages/libutempter.git;branch=master \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050014 file://0001-Fix-macro-error.patch \
Brad Bishop19323692019-04-05 15:28:33 -040015 file://0002-Proper-macro-path-generation.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050016 file://libutempter-remove-glibc-assumption.patch \
17 "
Patrick Williamsb48b7b42016-08-17 15:04:38 -050018
19S = "${WORKDIR}/git/${BPN}"
20
21CFLAGS += "-DLIBEXECDIR=${libexecdir}"
22
23do_compile() {
24 oe_runmake \
25 libdir=${libdir} \
26 libexecdir=${libexecdir}
27}
28
29do_install() {
30 oe_runmake install \
31 DESTDIR=${D} \
32 libdir="${libdir}" \
33 libexecdir="${libexecdir}" \
34 includedir=${includedir} \
35 mandir=${mandir}
36
37 rm -f ${D}${libdir}/*.a
38}
39
Patrick Williams213cb262021-08-07 19:21:33 -050040FILES:${PN} = "${libdir}/*.so.*"
41FILES:${PN} += "${libexecdir}/utempter/utempter"
42FILES:${PN}-dbg += "${libexecdir}/utempter/.debug/utempter"