blob: f8b4af0c4f430c388016a0d1acebea29cc472c98 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Smart card library and applications"
2DESCRIPTION = "OpenSC is a tool for accessing smart card devices. Basic\
3functionality (e.g. SELECT FILE, READ BINARY) should work on any ISO\
47816-4 compatible smart card. Encryption and decryption using private\
5keys on the smart card is possible with PKCS\
6such as the FINEID (Finnish Electronic IDentity) card. Swedish Posten\
7eID cards have also been confirmed to work."
8
9HOMEPAGE = "http://www.opensc-project.org/opensc/"
10SECTION = "System Environment/Libraries"
Andrew Geissler9aee5002022-03-30 16:27:02 +000011LICENSE = "LGPL-2.0-or-later"
Andrew Geissler8fc454f2020-12-11 16:27:59 -060012LIC_FILES_CHKSUM = "file://COPYING;md5=cb8aedd3bced19bd8026d96a8b6876d7"
Brad Bishop19323692019-04-05 15:28:33 -040013
Andrew Geissler8fc454f2020-12-11 16:27:59 -060014#v0.21.0
Andrew Geisslerd159c7f2021-09-02 21:05:58 -050015SRCREV = "c902e1992195e00ada12d71beb1029287cd72037"
Andrew Geissler595f6302022-01-24 19:11:47 +000016SRC_URI = "git://github.com/OpenSC/OpenSC;branch=master;protocol=https \
Brad Bishop19323692019-04-05 15:28:33 -040017 "
Brad Bishop8410d612019-11-25 09:40:59 -050018DEPENDS = "virtual/libiconv openssl"
Brad Bishop19323692019-04-05 15:28:33 -040019
20S = "${WORKDIR}/git"
21inherit autotools pkgconfig bash-completion
22
23EXTRA_OECONF = " \
24 --disable-static \
Brad Bishop19323692019-04-05 15:28:33 -040025 --disable-ctapi \
26 --disable-doc \
Andrew Geisslereff27472021-10-29 15:35:00 -050027 --disable-strict \
Brad Bishop19323692019-04-05 15:28:33 -040028"
29EXTRA_OEMAKE = "DESTDIR=${D}"
30
Brad Bishop8410d612019-11-25 09:40:59 -050031PACKAGECONFIG ??= "pcsc"
32
33PACKAGECONFIG[openct] = "--enable-openct,--disable-openct,openct"
Brad Bishope42b3e32020-01-15 22:08:42 -050034PACKAGECONFIG[pcsc] = "--enable-pcsc,--disable-pcsc,pcsc-lite,pcsc-lite pcsc-lite-lib"
Brad Bishop8410d612019-11-25 09:40:59 -050035
Patrick Williams213cb262021-08-07 19:21:33 -050036RDEPENDS:${PN} = "readline"
Brad Bishop19323692019-04-05 15:28:33 -040037
Patrick Williams213cb262021-08-07 19:21:33 -050038FILES:${PN} += "\
Brad Bishop19323692019-04-05 15:28:33 -040039 ${libdir}/opensc-pkcs11.so \
40 ${libdir}/onepin-opensc-pkcs11.so \
41 ${libdir}/pkcs11-spy.so \
42"
Patrick Williams213cb262021-08-07 19:21:33 -050043FILES:${PN}-dev += "\
Brad Bishop19323692019-04-05 15:28:33 -040044 ${libdir}/pkcs11/opensc-pkcs11.so \
45 ${libdir}/pkcs11/onepin-opensc-pkcs11.so \
46 ${libdir}/pkcs11/pkcs11-spy.so \
47"
Brad Bishop8410d612019-11-25 09:40:59 -050048
49BBCLASSEXTEND = "native"