blob: ad6a7501c58fe4346f13a23eed078224b7dffbf9 [file] [log] [blame]
Brad Bishop15ae2502019-06-18 21:44:24 -04001SUMMARY = "Protocol plugin for New Yahoo (2016) for Adium, Pidgin, Miranda and Telepathy IM Framework"
2SECTION = "webos/services"
Andrew Geissler9aee5002022-03-30 16:27:02 +00003LICENSE = "GPL-3.0-only"
Brad Bishop15ae2502019-06-18 21:44:24 -04004LIC_FILES_CHKSUM = "file://LICENSE;md5=84dcc94da3adb52b53ae4fa38fe49e5d"
5
6DEPENDS = "pidgin json-glib glib-2.0"
7
8inherit pkgconfig
9
Andrew Geissler595f6302022-01-24 19:11:47 +000010SRC_URI = "git://github.com/EionRobb/funyahoo-plusplus;branch=master;protocol=https"
Brad Bishop15ae2502019-06-18 21:44:24 -040011SRCREV = "fbbd9c591100aa00a0487738ec7b6acd3d924b3f"
12
13S = "${WORKDIR}/git"
14
15do_compile() {
16 oe_runmake CC="${CC}" CXX="${CXX}" EXTRA_INCLUDES="${TARGET_CFLAGS}" AR="${AR}";
17}
18
19do_install() {
20 oe_runmake DESTDIR="${D}" install;
21}
22
Patrick Williams213cb262021-08-07 19:21:33 -050023FILES:${PN} += " \
Brad Bishop15ae2502019-06-18 21:44:24 -040024 ${libdir} \
25"