blob: 14b1aaf01c14d24142c09ec1583ac1d875bfccf7 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "multi-protocol instant messaging client"
Andrew Geisslerac970dd2021-02-12 15:32:45 -06002
Brad Bishopd7bf8c12018-02-25 22:55:05 -05003SECTION = "x11/network"
Andrew Geissler9aee5002022-03-30 16:27:02 +00004LICENSE = "GPL-2.0-only"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05005LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
Brad Bishop996bc452019-12-02 13:05:15 -05006DEPENDS = "python3 virtual/libintl intltool-native libxml2 gconf glib-2.0-native"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05007
Brad Bishop996bc452019-12-02 13:05:15 -05008inherit autotools gettext pkgconfig gconf perlnative python3native
Brad Bishopd7bf8c12018-02-25 22:55:05 -05009
10SRC_URI = "\
11 ${SOURCEFORGE_MIRROR}/pidgin/pidgin-${PV}.tar.bz2 \
12 file://sanitize-configure.ac.patch \
13 file://purple-OE-branding-25.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050014"
15
Andrew Geisslere34f8962021-04-15 15:53:51 -050016SRC_URI[sha256sum] = "19654ad276b149646371fbdac21bc7620742f2975f7399fed0ffc1a18fbaf603"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050017
18PACKAGECONFIG ??= "gnutls consoleui avahi dbus idn nss \
19 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 gtk startup-notification', '', d)} \
20"
21PACKAGECONFIG[farsight2] = "--enable-farstream,--disable-farstream,farsight2"
22# --disable-gstreamer compile without GStreamer audio support
23# --disable-gstreamer-video
24# compile without GStreamer 1.0 Video Overlay support
25# --disable-gstreamer-interfaces
26# compile without GStreamer 0.10 interface support
27# --with-gstreamer=<version>
28# compile with GStreamer 0.10 or 1.0 interface
29PACKAGECONFIG[gstreamer] = "--enable-gstreamer,--disable-gstreamer,gstreamer"
30PACKAGECONFIG[vv] = "--enable-vv,--disable-vv,gstreamer"
31PACKAGECONFIG[idn] = "--enable-idn,--disable-idn,libidn"
32PACKAGECONFIG[gtk] = "--enable-gtkui,--disable-gtkui,gtk+"
33PACKAGECONFIG[x11] = "--with-x=yes --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR},--with-x=no,virtual/libx11"
34PACKAGECONFIG[startup-notification] = "--enable-startup-notification,--disable-startup-notification,startup-notification"
Andrew Geisslerac970dd2021-02-12 15:32:45 -060035PACKAGECONFIG[consoleui] = "--enable-consoleui --with-ncurses-headers=${STAGING_INCDIR},--disable-consoleui,libgnt"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050036PACKAGECONFIG[gnutls] = "--enable-gnutls --with-gnutls-includes=${STAGING_INCDIR} --with-gnutls-libs=${STAGING_LIBDIR},--disable-gnutls,gnutls,libpurple-plugin-ssl-gnutls"
37PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus dbus-glib"
38PACKAGECONFIG[avahi] = "--enable-avahi,--disable-avahi,avahi"
39PACKAGECONFIG[nss] = "--enable-nss,--disable-nss,nss nspr,libpurple-plugin-ssl-nss"
Andrew Geisslere34f8962021-04-15 15:53:51 -050040PACKAGECONFIG[cyrus-sasl] = "--enable-cyrus-sasl,--disable-cyrus-sasl,cyrus-sasl"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050041
42EXTRA_OECONF = " \
43 --disable-perl \
44 --disable-tcl \
45 --disable-gevolution \
46 --disable-schemas-install \
47 --disable-gtkspell \
48 --disable-meanwhile \
49 --disable-nm \
50 --disable-screensaver \
51"
52
Brad Bishopd7bf8c12018-02-25 22:55:05 -050053OE_LT_RPATH_ALLOW=":${libdir}/purple-2:"
54OE_LT_RPATH_ALLOW[export]="1"
55
Andrew Geisslerac970dd2021-02-12 15:32:45 -060056PACKAGES =+ "libpurple-dev libpurple finch finch-dev ${PN}-data"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080057
Patrick Williams213cb262021-08-07 19:21:33 -050058RPROVIDES:${PN}-dbg += "libpurple-dbg finch-dbg"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050059
60LEAD_SONAME = "libpurple.so.0"
Patrick Williams213cb262021-08-07 19:21:33 -050061FILES:libpurple = "${libdir}/libpurple*.so.* ${libdir}/purple-2 ${bindir}/purple-* ${sysconfdir}/gconf/schemas/purple* ${datadir}/purple/ca-certs"
62FILES:libpurple-dev = "${libdir}/libpurple*.la \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050063 ${libdir}/libpurple*.so \
64 ${libdir}/purple-2/*.la \
65 ${libdir}/purple-2/libjabber.so \
66 ${libdir}/purple-2/liboscar.so \
67 ${libdir}/purple-2/libymsg.so \
68 ${datadir}/aclocal"
Patrick Williams213cb262021-08-07 19:21:33 -050069FILES:finch = "${bindir}/finch"
70FILES:finch-dev = "${libdir}/finch/*.la"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050071
Patrick Williams213cb262021-08-07 19:21:33 -050072FILES:${PN} = "${bindir} ${datadir}/${PN} ${libdir}/${PN}/*.so \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050073 ${datadir}/applications"
Patrick Williams213cb262021-08-07 19:21:33 -050074RRECOMMENDS:${PN} = "${PN}-data libpurple-protocol-irc libpurple-protocol-xmpp"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050075
Patrick Williams213cb262021-08-07 19:21:33 -050076FILES:${PN}-data = "${datadir}/pixmaps ${datadir}/sounds ${datadir}/icons ${datadir}/appdata"
77FILES:${PN}-dev += "${libdir}/${PN}/*.la"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050078
79PACKAGES_DYNAMIC += "^libpurple-protocol-.* ^libpurple-plugin-.* ^pidgin-plugin-.* ^finch-plugin-.*"
80
Patrick Williams213cb262021-08-07 19:21:33 -050081python populate_packages:prepend () {
Brad Bishopd7bf8c12018-02-25 22:55:05 -050082 pidgroot = d.expand('${libdir}/pidgin')
83 purple = d.expand('${libdir}/purple-2')
84 finch = d.expand('${libdir}/finch')
85
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000086 do_split_packages(d, pidgroot, r'^([^l][^i][^b].*)\.so$',
Brad Bishopd7bf8c12018-02-25 22:55:05 -050087 output_pattern='pidgin-plugin-%s',
88 description='Pidgin plugin %s',
89 prepend=True, extra_depends='')
90
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000091 do_split_packages(d, purple, r'^lib(.*)\.so$',
Brad Bishopd7bf8c12018-02-25 22:55:05 -050092 output_pattern='libpurple-protocol-%s',
93 description='Libpurple protocol plugin for %s',
94 prepend=True, extra_depends='')
95
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000096 do_split_packages(d, purple, r'^(ssl-.*)\.so$',
Brad Bishopd7bf8c12018-02-25 22:55:05 -050097 output_pattern='libpurple-plugin-%s',
98 description='libpurple plugin %s',
99 prepend=True, extra_depends='libpurple-plugin-ssl')
100
Andrew Geissler7e0e3c02022-02-25 20:34:39 +0000101 do_split_packages(d, purple, r'^([^l][^i][^b].*)\.so$',
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500102 output_pattern='libpurple-plugin-%s',
103 description='libpurple plugin %s',
104 prepend=True, extra_depends='')
105
Andrew Geissler7e0e3c02022-02-25 20:34:39 +0000106 do_split_packages(d, finch, r'^([^l][^i][^b].*)\.so$',
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500107 output_pattern='finch-plugin-%s',
108 description='Finch plugin %s',
109 prepend=True, extra_depends='')
110}