blob: 2203663c178152fe18d7336db7621f63c24dda5d [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "A filesystem snapshot utility based on rsync"
2HOMEPAGE = "http://www.rsnapshot.org"
3BUGTRACKER = "https://sourceforge.net/projects/rsnapshot/"
4SECTION = "console/network"
5
Andrew Geissler9aee5002022-03-30 16:27:02 +00006LICENSE = "GPL-2.0-only"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05007LIC_FILES_CHKSUM = "file://COPYING;md5=892f569a555ba9c07a568a7c0c4fa63a"
8
Patrick Williams213cb262021-08-07 19:21:33 -05009RDEPENDS:${PN} = "rsync \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050010 perl \
11 perl-module-dirhandle \
12 perl-module-cwd \
13 perl-module-getopt-std \
14 perl-module-file-path \
15 perl-module-file-stat \
Andrew Geisslerbbbd5f42020-10-30 15:42:48 -050016 perl-module-file-spec \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050017 perl-module-posix \
18 perl-module-fcntl \
19 perl-module-io-file \
20 perl-module-constant \
21 perl-module-overloading \
Andrew Geisslerbbbd5f42020-10-30 15:42:48 -050022 perl-module-ipc-open3 \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050023 "
24
Andrew Geissler69721092021-07-23 12:57:00 -040025SRCREV = "4dc82bfe6be3f83fcfa94946dcf6accfd6a18031"
26PV = "1.4.4+git${SRCPV}"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050027
Andrew Geissler595f6302022-01-24 19:11:47 +000028SRC_URI = "git://github.com/DrHyde/${BPN};branch=master;protocol=https \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050029 file://configure-fix-cmd_rsync.patch \
30 "
31
32S = "${WORKDIR}/git"
33
Andrew Geissler82c905d2020-04-13 13:39:40 -050034inherit autotools perlnative
Patrick Williamsb48b7b42016-08-17 15:04:38 -050035
36# Fix rsnapshot.conf.default:
37# don't inject the host path into target configs.
38EXTRA_OECONF += "--without-cp \
39 --without-rm \
40 --without-du \
41 --without-ssh \
42 --without-logger \
43 --without-rsync \
44 ac_cv_path_PERL=${bindir}/perl \
Patrick Williamsddad1a12017-02-23 20:36:32 -060045 ac_cv_path_MOUNT=${base_bindir}/mount \
46 ac_cv_path_UMOUNT=${base_bindir}/umount \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050047 "
Patrick Williamsddad1a12017-02-23 20:36:32 -060048
49# Create 't/include.ac' before starting the autoreconf to fix configure
50# error: configure.ac:302: file 't/include.ac' does not exist
Patrick Williams213cb262021-08-07 19:21:33 -050051do_configure:prepend(){
Patrick Williamsddad1a12017-02-23 20:36:32 -060052 saved_dir=`pwd`
53 cd ${S}; ./autogen.sh
54 cd ${saved_dir}
55}