blob: 6f3d5ba59db911259f1d8424f71d234e972c7914 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Automatically give your module the ability to have plugins"
2DESCRIPTION = "Provides a simple but, hopefully, extensible way of \
3having 'plugins' for your module. Obviously this isn't going to be the \
4be all and end all of solutions but it works for me.\
5\
6Essentially all it does is export a method into your namespace that \
7looks through a search path for .pm files and turn those into class \
8names.\
9\
10Optionally it instantiates those classes for you."
11SECTION = "libs"
12
13AUTHOR = "Simon Wistow <simon@thegestalt.org>"
14HOMEPAGE = "https://github.com/simonwistow/Module-Pluggable"
15
Andrew Geissler9aee5002022-03-30 16:27:02 +000016LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050017LIC_FILES_CHKSUM = "file://README;beginline=322;endline=325;md5=086450ce010f6fda25db0b38fcc41086"
18
19SRCNAME = "Module-Pluggable"
Brad Bishop316dfdd2018-06-25 12:45:53 -040020SRC_URI = "${CPAN_MIRROR}/authors/id/S/SI/SIMONW/${SRCNAME}-${PV}.tar.gz"
21SRC_URI[md5sum] = "87ce2971662efd0b69a81bb4dc9ea76c"
22SRC_URI[sha256sum] = "b3f2ad45e4fd10b3fb90d912d78d8b795ab295480db56dc64e86b9fa75c5a6df"
23
24PR = "r1"
25
26UPSTREAM_CHECK_REGEX = "Module\-Pluggable\-(?P<pver>(\d+\.\d+))"
27UPSTREAM_CHECK_URI = "https://metacpan.org/release/${SRCNAME}"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050028
29S = "${WORKDIR}/${SRCNAME}-${PV}"
30
31inherit cpan
32
Patrick Williams213cb262021-08-07 19:21:33 -050033RDEPENDS:${PN} = " perl-module-base \
Patrick Williamsddad1a12017-02-23 20:36:32 -060034 perl-module-deprecate \
35 perl-module-file-basename \
36 perl-module-file-find \
37 perl-module-file-spec \
38 perl-module-file-spec-functions \
39 perl-module-if \
40 perl-module-test-more \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050041"
42
43BBCLASSEXTEND = "native"
44