blob: 293f421205bc64002ecaeb3ae8daaab89f815774 [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001SUMMARY = "LDAP Perl module"
2DESCRIPTION = "Net::LDAP is a collection of modules that implements \
3a LDAP services API for Perl programs. The module may be used to \
4search directories or perform maintenance functions such as adding, \
5deleting or modifying entries."
6
7SECTION = "libs"
8
Andrew Geissler9aee5002022-03-30 16:27:02 +00009LICENSE = "Artistic-1.0|GPL-1.0-or-later"
Brad Bishop26bdd442019-08-16 17:08:17 -040010LIC_FILES_CHKSUM = "file://README;beginline=3;endline=5;md5=4d6588c2fa0d38ae162f6314d201d89e"
11
12SRC_URI = "${CPAN_MIRROR}/authors/id/M/MA/MARSCHAP/perl-ldap-${PV}.tar.gz"
13
Andrew Geisslerac970dd2021-02-12 15:32:45 -060014SRC_URI[md5sum] = "d091ed00302f0276069bca9df9478744"
15SRC_URI[sha256sum] = "e2f389fe3e7a9e4b61488692919ad723b98f3b479b5288f610daa8c27995b351"
Brad Bishop26bdd442019-08-16 17:08:17 -040016
17S = "${WORKDIR}/perl-ldap-${PV}"
18
19inherit cpan ptest-perl
20
Patrick Williams213cb262021-08-07 19:21:33 -050021do_configure:prepend() {
Brad Bishop26bdd442019-08-16 17:08:17 -040022 perl -pi -e 's/auto_install_now.*//g' Makefile.PL
23}
24
25do_install_ptest() {
26 cp -r ${B}/data ${D}${PTEST_PATH}
27 chown -R root:root ${D}${PTEST_PATH}
28}
29
Patrick Williams213cb262021-08-07 19:21:33 -050030RDEPENDS:${PN} += " \
Brad Bishop26bdd442019-08-16 17:08:17 -040031 libconvert-asn1-perl \
32 libio-socket-ssl-perl \
33 libauthen-sasl-perl \
34 perl-module-integer \
35"
36
Patrick Williams213cb262021-08-07 19:21:33 -050037RDEPENDS:${PN}-ptest += " \
Brad Bishop26bdd442019-08-16 17:08:17 -040038 libxml-sax-base-perl \
39 libxml-sax-writer-perl \
40 perl-module-file-compare \
41 perl-module-perlio \
42 perl-module-test-more \
43"
44
45BBCLASSEXTEND = "native"