blob: ae4e6f72dac6e49c7f0b655663be3118b611cda4 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Convenience functions for dbus services in Python 2.x"
2HOMEPAGE = "https://github.com/nphilipp/python-slip"
3DESCRIPTION = "\
4The Simple Library for Python 2.x packages contain miscellaneous code for \
5convenience, extension and workaround purposes. \
6\
7This package provides slip.dbus.service.Object, which is a dbus.service.Object \
8derivative that ends itself after a certain time without being used and/or if \
9there are no clients anymore on the message bus, as well as convenience \
10functions and decorators for integrating a dbus service with PolicyKit."
11
12SECTION = "devel/python"
Andrew Geissler9aee5002022-03-30 16:27:02 +000013LICENSE = "GPL-2.0-or-later"
Andrew Geissler82c905d2020-04-13 13:39:40 -050014LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
15SRCNAME = "python-slip"
16
Andrew Geissler9aee5002022-03-30 16:27:02 +000017SRC_URI = "https://github.com/nphilipp/${SRCNAME}/releases/download/${SRCNAME}-${PV}/${SRCNAME}-${PV}.tar.bz2 \
18 file://9b939c0b534c1b7958fa0a3c7aedf30bca910431.patch \
19 file://0001-setup.py-Use-setuptools-instead-of-distutils.patch \
20 "
Andrew Geissler82c905d2020-04-13 13:39:40 -050021SRC_URI[sha256sum] = "c726c086f0dd93a0ac7a0176f383a12af91b6657b78a301e3f5b25d9f8d4d10b"
22
Andrew Geissler9aee5002022-03-30 16:27:02 +000023S = "${WORKDIR}/${SRCNAME}-${PV}"
24
Patrick Williams213cb262021-08-07 19:21:33 -050025do_compile:prepend() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050026 sed -e 's/@VERSION@/${PV}/g' ${S}/setup.py.in > ${S}/setup.py
27}
28
Patrick Williams213cb262021-08-07 19:21:33 -050029RDEPENDS:${PN} += "\
Andrew Geissler82c905d2020-04-13 13:39:40 -050030 ${PYTHON_PN}-six \
31"
32# http://errors.yoctoproject.org/Errors/Details/184713/
33# python-native/python: can't open file 'setup.py': [Errno 2] No such file or directory
34CLEANBROKEN = "1"
35
Brad Bishop19323692019-04-05 15:28:33 -040036inherit setuptools3
Andrew Geissler9aee5002022-03-30 16:27:02 +000037PIP_INSTALL_PACKAGE = "slip"