blob: 8889c83ee205fb6ab28e7ab19913f987ce33be2a [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001LICENSE = "GPL-3.0-or-later"
Brad Bishop19323692019-04-05 15:28:33 -04002LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
3
4require diffutils.inc
5
6SRC_URI = "${GNU_MIRROR}/diffutils/diffutils-${PV}.tar.xz \
7 file://run-ptest \
Brad Bishop79641f22019-09-10 07:20:22 -04008 file://0001-Skip-strip-trailing-cr-test-case.patch \
Andrew Geissler9aee5002022-03-30 16:27:02 +00009 file://0001-mcontext-is-not-a-standard-layout-so-glibc-and-musl-.patch \
Andrew Geisslerd159c7f2021-09-02 21:05:58 -050010 "
Brad Bishop19323692019-04-05 15:28:33 -040011
Andrew Geisslerd159c7f2021-09-02 21:05:58 -050012SRC_URI[sha256sum] = "a6bdd7d1b31266d11c4f4de6c1b748d4607ab0231af5188fc2533d0ae2438fec"
Brad Bishop19323692019-04-05 15:28:33 -040013
14EXTRA_OECONF += "ac_cv_path_PR_PROGRAM=${bindir}/pr --without-libsigsegv-prefix"
15
Andrew Geisslerd159c7f2021-09-02 21:05:58 -050016# latest gnulib is no longer able to handle this - I dare not try to fix that maze of abstractions and generators
17CFLAGS:mingw32 = " -DSA_RESTART=0"
18
Brad Bishop19323692019-04-05 15:28:33 -040019# Fix "Argument list too long" error when len(TMPDIR) = 410
20acpaths = "-I ./m4"
21
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000022EXTRA_OEMAKE:append:mingw32 = " LIBS='-lbcrypt'"
Brad Bishop19323692019-04-05 15:28:33 -040023inherit ptest
24
Patrick Williams213cb262021-08-07 19:21:33 -050025RDEPENDS:${PN}-ptest += "make perl"
Brad Bishop19323692019-04-05 15:28:33 -040026
27do_install_ptest() {
28 t=${D}${PTEST_PATH}
29 install -D ${S}/build-aux/test-driver $t/build-aux/test-driver
30 cp -r ${S}/tests $t/
31 install ${B}/tests/Makefile $t/tests/
32 sed -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
33 -e 's|${DEBUG_PREFIX_MAP}||g' \
34 -e 's:${HOSTTOOLS_DIR}/::g' \
35 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
36 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
37 -e 's|^Makefile:|_Makefile:|' \
38 -e 's|bash|sh|' \
39 -e 's|^top_srcdir = \(.*\)|top_srcdir = ..\/|' \
40 -e 's|^srcdir = \(.*\)|srcdir = .|' \
41 -e 's|"`$(built_programs)`"|diff|' \
42 -e 's|gawk|awk|g' \
43 -i $t/tests/Makefile
44}